WSJ videos on Brave Android are unplayable

Description of the issue:
It is impossible to play videos on the website using Brave Android, whether Brave shields are “up” or “down.” This occurs 100% of the time on Brave Android, and has been an issue for years.

Note: access to WSJ requires a subscription. But as the second largest newspaper in the US, hopefully someone on the development team has a subscription and can reproduce. Or can sign up for a free trial.

How can this issue be reproduced?

  1. Open Brave on Android.
  2. Navigate to and open any WSJ video, or article with a video. You can open the “Videos” section by clicking the three parallel lines at top-left, then clicking “Videos.”
  3. Click on any video (or article with a video).
  4. No matter how many times you click on the video (which has a play sign) the video never plays.

Expected result:
The video should play.

Brave Version( check About Brave):

Mobile Device details
Google Pixel 7 Pro

Additional Information:
This has been a very longstanding issue. It requires using a different browser to view any videos on WSJ (or live news streams). Which is a major problem for users.

I don’t have a subscription, but just playing the video on the front screen (testing on a oneplus 6 and a Fold 3). Both played fine here. Do those font page videos work?

Thank you very much for testing/replying.

No, those front page videos will not play for me. No matter whether:

  1. Logged in shields up
  2. Logged in shields down
  3. Private tab shields up
  4. Private tab shields down

Clicking on the video does nothing. It “blinks” once indicating it’s been clicked, but nothing happens/plays.

Can you try in Brave Beta (via the google play store), this creates a seperate profile for beta only.

Videos on work with Brave Beta.

Both “logged out” and “logged in!”

On the home page, and on the Videos page!

Is that due to a code change in Beta? How can I get that behavior in the stable release?!?

Thank you for all your help!

Maybe clear cache/cookies? also what are your shield settings on site?

I tried clearing all data for that site - no effect.

The issue occurs whether shields are “all up” or “all down.”

On a hunch, I just tried enabling autoplay for only (I have it turned off for all sites - for obvious reasons). Now, when I click on videos, it works.

So it seems to be a bug with autoplay. It’s not just preventing autoplay - it’s preventing users from playing videos they click on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.