Brave will not play WSJ videos unless "ads and trackers blocked" is turned off

Brave will not play certain videos on WSJ.com unless “ads and trackers blocked” under Brave Shields turned off. And, the shields being on slows down Brave due to high CPU usage.

Examples:
Video 1
or
Video 2

It shows a “spinning wheel” like it’s loading. Turning off the shields (which is slow to do) or “ads and trackers blocked” will show the video.

Another interesting note: When shields are up on this site, Brave utilizes the CPU around ~20-25%. When turning off shields, CPU usage goes back to normal.

Expected result is the video plays without having to disable shields. Also, if shields are up, it should not use greater than average CPU.

Reproduces 100% of the time on those links above. Other videos could be tested.

Brave version 0.58.16 Chromium: 71.0.3578.98 (Official Build) (64-bit)

1 Like

I’m able to play the video, but the site looks buggy and make Brave hang a bit before loading the video.

  • With an adblocker, I can play the video
  • Without, I can play but there is ads before the video

But I repeat, it’s a bit long to load.

Thanks for reporting guys.
I think we have an issue logged for this already. If not I’ll write one up - either way I know WSJ has given us some trouble in the past. Sorry for the inconvenience.
Let me see if I can dig the issue up.

1 Like

To add more information. For me I still leave the shields up, however, I have to enable cookies to see the stock graphs, otherwise they just are blank.

This topic was automatically closed after 30 days. New replies are no longer allowed.