Instagram videos do not play in 1.2.0 - also videos on major news sites

Description of the issue: Instagram videos do not play

Steps to Reproduce (add as many as necessary):

  1. Open any Instagram video
  2. Tap to play
  3. Also videos on msnbc.com, nbcnews.com and foxnews.com do not play (https://www.msnbc.com/david-gura/watch/cbp-reassignments-bottleneck-business-at-the-southern-border-1475796547604 or https://www.msnbc.com/rachel-maddow/watch/new-documentary-looks-at-how-trump-exploits-presidency-for-money-65034821782)
  4. http://demo.nimius.net/video_test/ - H.264 video (first one) does not play. Other Chromium browsers do play this video.

Actual Result (gifs and screenshots are welcome!): Video will not play

Expected result: Video plays

Reproduces how often: Every time

Brave Version(See the About Brave page in Settings): 1.2.0

Mobile Device details Different devices

Android/iOS Version Android 5.0.2 and 6.0.1

Additional Information: The same problem was recognized as a bug here. So from a user perspective it seems to be the same or a similar bug. Other Chromium based browsers do not have any problems playing videos.

1 Like

@Brave_user,
IG Videos seem to be working on my end – tested using Android 9 and 6.0.1. The issue you referenced above (Instagram videos do not play (new issue in 1.0.90)) has since been resolved. Can you tell me what your Shields settings are set to for the site(s)?

@Mattches
Shields are completely disabled.

Did you try http://demo.nimius.net/video_test/ ?
The first video does not play in Brave 1.2.0 but does so in other Chromium based browsers (tested with Samsung’s own browser) and previous versions of Brave.

I can verify this behavior on two devices with different Android versions.

I also did a downgrade to the previous Brave version. It does not have this issue. So it clearly has something to do with this latest version.

@Mattches
I have attached two screenshots of http://demo.nimius.net/video_test/. You can clearly see that the first video is broken in Brave but not in the Samsung browser (which of course is Chromium based).

brave version 1.2.0 is a beta version. So it comes with its risk. I can personally say the ad-blocking isn’t the greatest compared to v 1.1.2rc1

Because it is beta I report this bug before it goes stable and people begin to cry foul.

Am not crying foul find an issue open it on GitHub

I did not mean you personally. Beta phase is a time to find out the most obvious bugs, report them and get them fixed before the general release. And that is exactly what I am doing here.

1 Like

@Brave_user This is a known issue on 1.2.0. Please try on the next Chromium build that comes out. There are chances of items regressing during upgrades.

1 Like

Thanks @sriram. But would you mind explaining the quoted sentence to me? I have no idea what you mean.

Since we have custom code in the app when Chromium update happens some of them might break and cause regressions. Such issues will be fixed before we get onto release. Do appreciate your help in testing out the early beta application. :+1:

1 Like

All of mentioned sites work for me except foxnews.com, it seems to be loading videos forever

Most videos don’t play on 1.20. YouTube works but not all videos.

That is correct. Video play back failure is know for that build.

1 Like

I can confirmed it is fixed in Brave v1.2.0-rc.1.

This topic was automatically closed after 30 days. New replies are no longer allowed.