Windows Tasks "New Window" and "New Private Window" broken after reinstall

I’m using the latest version of Windows 10 and Brave V1.19.88. Yesterday, I noticed Brave Rewards ads weren’t working. I reinstalled Brave. Now, the rewards page is working, but I can no longer right click the Brave taskbar icon and select “New Window” or “New Private Window”.

I have tried removing/adding back to taskbar and reinstalling Brave.

Is this the proper place to ask for tech support?

Okay, thanks for sharing me this topic @prebrook.

I don’t think this should happen. Did you try to clear the cache?

@Markook , I tried clearing the cache to no avail. If I right click the Brave icon, it now looks like this:


If I try to run the task, I get:


This is only happening on the Windows 10 machine where I uninstalled and reinstalled. I am also running Brave on a Windows 10 laptop and a Debian based Linux VM, and it works fine on both of those.

It seems that in the installation the executables of new window and new private window are not created

Do you have any antivirus?. Maybe your antivirus is removing these executables during the installation

Windows Defender is installed

Can you check if it blocked something of Brave?

Nothing was blocked or quarantined.

Ok. Have you tried installing the standalone version available in github?

I dont know if that can help but maybe it will install the brave browser correctly

No, I was using the installer from the website. I can try that after work. Thanks.

@prebrook ,
First, can you please confirm that you’re using the latest version of the browser (1.19.90) at this time? If not, please ensure that is the update you’re installing. Additionally, even if you can’t open a Private/Private w/tor window from the shortcut icon in the task bar, if the browser is open can you still successfully open a private or private w/tor window?



Inside the browser, all of the “Open link in” functions work correctly.

Thanks for confirming.
This is certainly a strange issue and I’m not sure I’ve ever encountered it before. I know it may seem cumbersome, but can you try downloading the Beta version of the browser (at least temporarily), pin the shortcut and tell me if all the options appear or if the you get the same issue? Note that installing the Beta will not delete or overwrite any data from your current Brave installation and will run entirely separately.

If I install the beta and pin it to the taskbar, it doesn’t have any right click tasks associated with it:





I was able to get this working by doing the following:

  1. Remove Brave taskbar icon

  2. Run CCleaner and let it clear jump lists

  3. Right click taskbar → Settings → Start

  4. Turn “Show recently opened items in Jump Lists on Start or the taskbar and in File Explorer Quick Access” off

  5. Turn “Show recently opened items in Jump Lists on Start or the taskbar and in File Explorer Quick Access” on

  6. Add Brave taskbar icon

I still appreciate all of the help @Mattches and @Markook . Have a good weekend.