Win10 Brave No Audio / Doesn't even show in Adv. Audio Settings

Description of the issue: Brave does not show up in Windows 10 sound mixer, advanced sound settings, and the audio that should be played does not come through my headphones
How can this issue be reproduced?

  1. Launch Brave
  2. Go to any site with audio or video (with audio) content
  3. Check sound mixer, settings, headphones - no audio anywhere, and Brave isn’t listed

Expected result: Audio showing up in system’s settings, and following that - heard by the user

Brave Version( check About Brave): Version 1.11.97 Chromium: 84.0.4147.89 (Official Build) (64-bit)

Additional Information:
I love the browser and used it for everything but for the last month or so I’ve been completely unable to get any audio at all from Brave. Every now and then I’ve tried to read up on the issue and see what might be a problem but nothing that

I have found several topics about having audio issues with Brave and went through and tried all the suggestions that I could find.

As such, I included a screenshot taken which shows:
The multimedia section of inetcpl.cpl has audio enabled (one suggestion)
The advanced audio settings for Win10 which doesn’t show Brave (ALL active audio sources should be listed regardless of device) - I have tried hitting “Reset” and it didn’t do anything to help.
The top section of the Brave browser showing that A) the current tab of Netflix has active audio (symbol on the tab), B) there are no issues with the site being muted which would be shown in the address bar

Also, I have tried turning Hardware Acceleration off, it didn’t help, tried turning it on again - still didn’t help. Tried turning it off again (since I saw another article recommending that) and it’s still not working.

I have also uninstalled Brave, restarted the PC, installed Brave, and restarted the PC. Full clean reboots.

If there are any further suggestions for things to try, please let me know. Thank you!

Working fine
Try uninstalling audio driver from device manager and then check on reboot

I appreciate you taking the time to make a suggestion, but unfortunately that won’t accomplish anything for me. I have too many different audio devices each with their own drivers to try that - and Brave doesn’t show up for any of them. I have tried changing Window’s default audio device to each of them, and even with reboots Brave still won’t show up in either the normal volume mixer (what you are showing there in your screenshot) nor in the Advanced Audio Settings (which shows all active audio sources across all devices)

Brave’s audio functioned perfectly fine until about a month ago, at which point for no discernible reason it stopped. Audio works perfectly well on every other program on the PC, including Firefox, Edge, and Internet Explorer.

Also, for future reference:
“Working fine” is not a helpful comment - that simply lets other people know it’s working for you. I assume the majority of people don’t have an issue with Brave’s audio, but in my case I have checked, double checked, and triple checked everything I can think of and it’s still not functioning. Other people letting me know that it works for them doesn’t help. :slight_smile:

As you can see, even if I mess around in the advanced settings and change all the audio sources, everything still shows up there - every application I launch that has audio appears, I can change what their source is (normally everything says “default” because that’s what it’s supposed to say - for the sake of making my point I manually set a few of them to different audio devices)

Obviously when I put my headphones on while checking this it was a confusing mess, since I had a game, pandora music, a youtube video running in IE, firefox running netflix… But in spite of the fact that Brave had a youtube video running (visually functioning fine) - and showed that its active tab was producing sound - and wasn’t marked as muted anywhere – still no audio, and it didn’t show up in the advanced sound settings. Even ShareX when I took a screenshot popped up in the advanced sound settings no problem when it made its little “ding” sound letting me know it took a screenshot successfully (so I took another one to include that).

I don’t know where the problem is, but something isn’t working correctly, and it isn’t my audio devices - unless everything else about my computer is so broken that it all works (but I don’t think that’s the case :wink: )

Meh. I works fine in Edge. Brave bug.

Unfortunately that doesn’t help me with getting the audio to work in Brave. Thank you for commenting though :slight_smile:

Can you try creating a new browsing profile (Menu --> Create new profile), visit Youtube (or some other site where you stream audio/video content) and see if you get the audio to come through or if you get the same results?

I just created a new profile and relaunched Brave - no audio still, and it won’t show up in the advanced sound settings either.
I tried rebooting the PC as well and as it still isn’t working, I have deleted the new profile and gone back to the original.

This is more-or-less a fresh profile anyways, since I fully uninstalled, rebooted, reinstalled, rebooted Brave previously in an attempt to fix things.

Thank you for the suggestion!

Can you try simply re-running the Brave installer? This will not overwrite any data, but it can sometimes put things back where they need to go (with respect to file systems).

Some questionably good news.

Background information that you can probably skip over but is here to be fully comprehensive; go to the next set of lines.

I’ve been using REAPER which is a tool which I’m able to use to route audio to different sources - it’s nearly impossible to do this effectively with the native Windows tools, so I’ve been using REAPER for 3-5 years by now. On a day-to-day basis, I just use a profile I’ve adjusted over time which sets the volume for certain categories of applications. Most (including web browsers) I don’t have any special setting for changing where they’re routed, and Windows controls their destination. Things like Pandora and Discord, I manually tweak either inside their program (Discord) or from REAPER (Pandora) to go into their own categories, and all games inside my Steam library are automatically redirected to the “Games” channel. In the past, I ran into a total of two programs that had issues with the program, both were multiplayer games that used anti-cheat software which erroneously tagged Synchronous Audio Router (the software that provides the additional virtual audio channels for REAPER to use), and as a result the audio went into the void. One of those games fixed the issue, the other I don’t know about.

I’ve been using Brave for at least a year and a half now, and have had no issues until a month ago, and I’ve been using REAPER for several years with very few issues (see above if you care).
While testing one of your suggestions, I rebooted the computer and launched Brave before REAPER and heard audio coming out of my headphones which were sitting on the desk. Opened the advanced sound settings, and lo-and-behold, Brave was showing up again like it used to back in the beginning.

I had previously tried turning REAPER off and relaunching Brave, but this didn’t work in the past - hence I didn’t mention it in the post above. I closed Brave, launched REAPER - and then opened Brave again, and we’re back to the same no-sound issue. Closed both, launched Brave - still no sound, even though REAPER is 100% shut down.

Rebooted the PC, tried brave first, it works (though it’s super loud since it’s not being adjusted so I can hear it even with the headphones sitting on the desk). Closed brave, tried it again 3 times to confirm that it works every time. Tried multiple sites, refreshing pages - everything is fine.

Closed Brave again, launched REAPER and immediately shut it down, launched Brave. No matter what I do, it’s impossible to get the audio to show back up.

So, if I turn REAPER on at any point, I need to reboot the PC in order to get audio in the Brave browser.

I am truly at a loss here, because A) now I have something that’s technically a solution to my problem, but B) this wasn’t an issue for the longest time, and only recently became a problem – and while I do prefer the Brave browser, I simply can’t drop REAPER at this point.

As far as the setup for REAPER, all I use are the bare minimums - the application itself, ASIO4ALL to provide some of the stuff it needs, and Synchronous Audio Router to provide the virtual audio inputs/outputs so I can have multiple channels.

If you guys are able to figure out what’s going on, I’d be ecstatic - since I really do like Brave and have gotten very used to it over the past couple years, but if not I guess I’ll be stuck dual wielding with Firefox for any audio/video stuff. That said, I don’t know if it’s an issue with Brave, REAPER, Windows, or one of the subsidiary applications.

Thank you again for the suggestion. I’ve got mixed feelings about my findings though, since I’m glad I have an idea about what’s going on but… Disappointed that the only fix I can see so far is not one I can use :frowning:

That’s a lot of information – thank you for taking the time to write it all out :slight_smile:

Let me rope a developer into this who may have a better of understanding what’s going.


I appreciate you giving it attention.

In my ideal world the issue will be resolved, regardless of whether it’s a problem in Brave, Chromium, REAPER, or Win10 - but obviously as a simple user, I don’t even know where to begin trying to figure out what interaction between these is causing the issue :frowning:

Thank you again for your assistance :slight_smile:

1 Like

@shiverczar thanks for sharing the information - I’ve read through and I’m not sure where to start troubleshooting. Brave definitely isn’t doing anything special with regards to audio… there are two flags available under brave://flags/ (search for audio) - but I don’t think those would resolve what you’re seeing

Is it possible there is a problem with REAPER? For example, do you have a way to back up your profile and then try a fresh profile on REAPER? It would be great to know that a stock install works with Brave (or Chrome/Chromium if you wanted to try installing that too). Besides the profile, I would try reporting the issue on the forums if you haven’t already:

Thank you for the response.
I have no idea what the issue is either, and if it weren’t for the fact that Brave is currently the only program I have found in the last few years where I have an issue, I’d be more focused on the REAPER side as well. I have done a re-install of REAPER (it’s one of the first things I tried) but I haven’t gotten the time to fully clean it out and reinstall - that takes a bit more time :slight_smile:

The only thing I’m aware of that’s different between Brave and other programs that I’ve noticed in the process of troubleshooting is that Windows seems to only register Brave as an audio source when it’s actively producing sound. When Discord, Outlook, Firefox, Steam, Pandora, and any of the games I launch are started - they show up in the app list under Win10’s advanced sound settings as soon as they are opened, even though none of them have produced any sound yet.

By comparison, if I restart the computer and launch Brave [not having launched REAPER so Brave’s audio works] and go to any media-less website, Brave does not show up on the list - only when I go to a site with a video or something on it will Brave show up.

I haven’t put much time into this lately - been focused on other things right now, but I am curious about why Brave doesn’t show up in the mixer or adv. settings until after a video is being played? It may help me with trying to identify what’s going on exactly if I know why that is.

Thank you!

Edit: I did try (just for completion’s sake) toggling those two audio-related flags each way. Made no difference (as you expected)

@clifton, @Mattches,
Just wanted to update you since I finally got around to testing it with Chrome - same exact issue in Chrome.

I had absolutely no issues with REAPER/Brave working perfectly fine with each other at least until April. Was unaware of any issues between then and mid July. The reason I don’t know an exact time is that I was watching a bunch of videos for the first couple months of the pandemic and then stopped, so I can’t narrow down the window of when something broke, unfortunately.

At this point, Brave (and Chrome) are the only two applications that I am aware of that have any issues, but at least now I know that the issue exists in Chrome as well which provides a little bit more information…

(Again, when REAPER is running neither program even shows up in the Advanced sound settings on Win10 which should show every single program with audio; even though the browser itself has the nice little “I’m making sound in this tab” icon)

So, I will be migrating slightly to the cockos and chrome forums and see if I can get any assistance in those places.

Hopefully I’ll either find something or make the issue known to someone that can fix it :slight_smile:

Thanks for your efforts, guys!

Thanks for following up @shiverczar - dang. Sorry to hear it’s a Chrome issue too

With that, you can create a Chromium issue at using the details provided (I believe you’ll need a Google account to login before you can create a new issue). If you are able to do that, I can create an issue to track this on our side. Reporting the issue would also provide updates as Chromium devs triage / diagnose the issue too

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.