Why Oh Why is There 1/2" Bar At Top Of Browser?

Brave Browser insists on placing about 1/2" bar at the top of the browser window. This is such an annoying waste of space on my 13" MacBook Pro. It occurs whether or not “Always Show Bookmarks”, “Always Show ToolBar in Full Screen” and/or “Always Show URLs” is toggled ON or OFF. And what’s more frustrating is occasionally, it goes away and displays correctly without it—but only for awhile. After a minimization/return to full screen or two, it’s back to placing the 1/2" bar up there again. Why on earth waste so much screen space on the browser?

This is on a MacBook Pro Apple M1 chip using Ventura 13.2.1, but it was occurring on Monterey prior to a recent update as well.

Brave Version: Brave is up to date. Version 1.49.120 Chromium: 111.0.5563.64 (Official Build) (arm64)

Hi @MIGGSEYE welcome back to Community :wave:

Thanks for bringing this to our attention. I am able to reproduce this on both Brave and Chrome with no issue on Firefox or Safari.
I brought this to the attention of our team to confirm if this is specific to chromium based browsers.

Hi @MIGGSEYE

I do believe I figured it out. Follow the instructions below and let me know if you have any success.

In settings → desktop & dock → automatically hide and show the menu bar → set to in full screen only

2 Likes

Wow! Thank you. This has been bugging me for months now. I finally got frustrated enough to post about it yesterday… and you solved it sooooo quickly. THANK YOU! You are the best!

2 Likes

Yay! Great news!

I’m glad to hear that it resolved your issue.

Thank you for choosing Brave and we look forward to continuing to provide you with great service.