Why does Hardware Acceleration Slow Down Brave so much

I’m just wondering why does Hardware Acceleration slow down Brave down so much randomly with laggy graphics and terrible performance out of nowhere? Been using Brave for months and suddenly today when I noticed such a performance hit where sites were loading so slow with graphics lag. I noticed today as I updated to Brave Version 1.35.100 the Hardware Acceleration took a huge performance hit and when I turned it off what a huge difference of everything running so nice and smooth again. I thought hardware acceleration is suppose to make it run much faster and smoother and not laggy. I have a pretty powerful system but this is becoming quite annoying that I actually have to turn this function off in order to use Brave to it’s full speed.

Windows 11
Nvidia RTX 2070 (Latest Driver)
64 GB RAM
I9 Processor
Version 1.35.100 Chromium: 98.0.4758.87 (Official Build) (64-bit)

1 Like

How are you testing the performance? I’m on a 2080S here, most of the GPU usage for myself is just youtube playback (and occasionally Netflix/Disney). What about testing Brave in private mode with no extensions.

1 Like

You didn’t provide the exact model of your CPU. Are you on a laptop by any chance?

1 Like

I found out that if you go to brave://flags and search for ANGLE graphics backend the “Default” setting is what slows down brave so much when you have hardware acceleration enabled. I switched it out to “OpenGL” and a big performance difference. The Default setting that Brave is giving everyone is probably outdated and slowing down many people.

Also try D3D11ON12 it also may work better than “OpenGL” experiment with these two values and see which one gives you better results as results may vary from system to system.

1 Like

Which flag did you adjust @flasher777

It’s called “ANGLE graphics backend” in the flags section. Change it to “Open GL”.

flasher777,

Details of that flag:

Choose the graphics backend for ANGLE. The OpenGL backend is soon to be deprecated on Mac, and may contain driver bugs that are not planned to be fixed. The Metal backend is still experimental, and may contain bugs that are still being worked on. The Metal backend should be more performant, but may still be behind the OpenGL backend until fully released. – Mac

Related article [09/24/2018]: “The end of OpenGL and OpenCL on the Mac” at:

https://arstechnica.com/features/2018/09/macos-10-14-mojave-the-ars-technica-review/12/

This does not work for me and I have the same problem as OP but with youtube everything flickers and changes video colors.

@bdog27 , @flasher777 ,

In brief, try to reduce the workload on the CPU(s) and the GPU, caused by processes other than Brave Browser.

Use the Windows Task Manager window (tools), and the Brave Browser Task Manager (search for that, in the Help menu). You might also use the Developer Tools >> Network (search for Developer Tools, in the Help menu). For helping you to diagnose, What are the excess processes that can be dispensed with, while testing?

Go thru the Brave Browser Settings, and Disable what you can, in order to relieve Brave Browser of some burdens and tasks (extensions?) . . . and afford Brave Browser some focus upon the video website.

Quit everything. Restart your Windows OS computer. Run Brave Browser and open a “New Private Window” . . . and use that window, for testing the video URL and performance. If a “New Private Window” inhibits things . . . then try the “New Window”.

And, use windows, not tabs. A new window per video URL address.

I would test in Brave Beta and Nightly to see if there is any improvements, we’ve had reports Chrome release is also having similar issues.

I’ve been having this issue with my Windows11 machine as of late (AMD card). Can confirm that changing this setting to “D3D11on12” fixed my issues and VASTLY improved performance playing video.

2 Likes

@FoxBJK ,

UPDATE Monday, 20220307

With release of Brave Browser v.1.36.111 (Chrome 99.0.4844.51) – re Chrome release notes contained Security Fixes for ANGLE:

[$10000][1289383] High CVE-2022-0789: Heap buffer overflow in ANGLE. Reported by SeongHwan Park (SeHwa) on 2022-01-21

[$7000][1285885] High CVE-2022-0792: Out of bounds read in ANGLE. Reported by Jaehun Jeong(@n3sk) of Theori on 2022-01-11

Ref.: “https://chromereleases.googleblog.com/search/label/Stable%20updates+Desktop%20Update

Nobody actually responded to the question in the title… Anyone has a clue? Would love to actually understand why Hardware Acceleration is slowing Brave so much, it doesn’t seem to be as bad on Chrome, pretty ironic considering Brave is bragging about getting better performances then Chrome, i ain’t sure about that…

Some people reports amounts of RAM and GPU consumed ridiculously high, like 15Gb. My boss has like a 50-100 tabs opened on his Chrome browser with HA enabled, and it’s consuming less then my Brave often does with less then 10… It seems it will eat more RAM if there’s more available on user PC… That’s pretty suspicious. Also it’s often the GPU Process that’s going through the roof. Sometimes i’m under the impression Brave is using it’s users excess ressources to mine crypto or something… Since it’s Open Source, i guess it would have been spotted though.

Switching to OpenGPL / D3D11on12 seems to help a bit, but clearly not as much as disactivating Hardware Acceleration. The RAM consumption is literally divided by 2-3 with HA disabled.

Edit: Actually OpenGPL / D3D11on12 doesn’t even seem to help that much in my case, going back to default actually consumes 100MB less for my current setup. D3D9 seems to be the best in my actual context. But HA disabled definitely is the way to go literally goes from 1,2-1,5 GB of RAM consumption to .500 MB… I really want to know what’s up with that.

1 Like

Post in another topic. Helps answer question?

Also in that post moderators suggest creating a new profile to see if the problem persists and pasting brave://gpu/. Not sure what that is about. You might want to take a look.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.