Brave is very slow. Hardware Acceleration already turned off

Brave is slow after a recent update. After doing some preliminary research, I turned off Hardware Acceleration.

It’s still slow on certain websites, most notably Youtube. I don’t know what else to do to diagnose its handling problems.

The HW acceleration is no different with other Chromium browsers, it’ll depend on the graphics driver (AMD and Intel drivers seem more problematic). My home machine is using a Nvidia 2080S, and had no issues with YT playback.

May help for some users.

1 Like

It’s unclear to me why youtube plays slowly on Brave on either setting, but Chrome and Firefox have no issue. I can only assume it has something to do with Brave.


Would you mind trying to create a new test profile (ensure you close the original profile window you had open) and tell me if Brave behaves the same way when using it?

Also pasting here (using pastebin) brave://gpu/ may help

No issues on the test profile so far.

@fanboynz Looks like the same things are enabled/disabled between the usual profile and the test profile.

It’s still not clear to me what’s happened, but ever since I created the test profile and now have the main profile distinct from the other, things appear to have become operable again.

I’ll report back if it changes, but as of right now I’m not experiencing any issues.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.