White videos on Youtube

Description of the issue:
When trying to play videos on Youtube, the sound is available but the video is only a white background. Additionally, it seems impossible to click on the video to start/pause it, I have to click the play/pause button.

How can this issue be reproduced?

  1. Start any video on Youtube.

Expected result:
The video should play normally but all that is shown is a white screen and the sound.

Brave Version( check About Brave):
Version 0.69.132 Chromium: 77.0.3865.90 (Official Build) (64-bit)

Additional Information:

@zigliara can you try disable “Hardware acceleration” in Brave’s Settings and see if it can solve your issue?

Thanks

1 Like

I’ve done that but it doesn’t help.

On a side note, I’ve also tried uninstalling and re-installing Brave, just to see whether I might have done something by mistake which should disappear when re-installing, but the behavior is the same. What surprises me though, is that even after re-install (using appcleaner to uninstall), Brave remembers exactly which tab were open before… So, obviously, some cache information is still present on the computer somewhere (event after restarting the computer).

As I mentioned earlier, it’s no longer possible to click on the video to pause or start it, I need to use the play/pause button. So it seems that there’s some kind of extra layer over the video window.

Also, when hovering over the “scroll bar” on the video, I still can see the thumbnails for the video.

yeah, “Hardware acceleration” worked for me before.

Doesn’t work for me. Tried to restart everything, but to no avail. Weird thing is it just happened suddenly, not even after an update…

It happened to me before, i used private windows and for some reason white videos stopped, then i found out about Hardware acceleration. Solved it for me… i apologize, i do not know how to assist further.

No worries, thanks for trying! Let’s hope someone else can help out :slight_smile:

1 Like

Can you clear the cookies/cache for youtube, and try in private mode?

Tried that (Clear browsing data, i.e. Download and Browsing history, “Cookies and other site data” as well as “Cached images and files”).

Restarted. Opened a Private window. Still doesn’t work…

Okay, try a clean profile, Close Brave.

Open explorer; got into C:\Users<username>\AppData\Local\BraveSoftware

Just rename the current profile “Brave-Browser”, then re-open Brave. It should start from a fresh setup. then re-test youtube

Ah, do you have any idea what the equivalent location would be for Mac?

Not sure with Mac, though a way around it would be to install a different Build (say the Brave-beta build), which should have its own profile

1 Like

Ok, so that did the trick! Thanks!

So, somehow, even though I’m tried to completely erase/uninstall and reinstall Brave, there’s still information stored somewhere, which I can’t delete (profile-related) and which has led to this issue.

Still don’t know what caused the issue though…

May help;

https://www.google.com/search?q=remove+application+profile+in+macos

Would recommend backing up your bookmarks/sensitive files, because it’ll remove them

So, I uninstalled Beta and re-installed the latest released version. Of course, same behavior (white Youtube).

But then, I created new profile (Person 2). This one works!

Any idea what could have affected my first profile (Person 1)?

FWIW, with apologies for duplicate content if the google search includes any of the following, all versions of Brave Browser in macOS create their own folders in your home folder (/Users/YOURUID/Library/Application Support/Brave Software). I have Release and Nightly installed, so mine looks like this (click image to enlarge):

Your profiles live in those folders, and usually unless you create a new profile with the manager, it’s just “Default.” For example, in my Brave-Browser-Nightly, the profile I usually use is Default and is the most recently modified folder, and I have several others in folders the browser cleverly named Profile 1, Profile 2, Profile 3, and Profile 4, as well as a backup copy of Default that I made in February (click image to enlarge):
image

Your bookmarks, settings, and extensions are stored in your profile folder, as you’d expect. In the Extensions folder, each extension has a folder named a bunch of gobbledy-gook, which, if you’re so inclined, you can identify by going to the extensions’ settings in the browser and noting the gobbledy-gook for it in the address bar.


image
image