Only with shields up, youtube videos are displayed blank white but sound plays

Last week I became to view youtube videos with Brave’s shields up. I changed no settings just prior to this happening. The video appeared black for the first couple days, now it appears white. I can not pause/play the video by clicking on it, I have to click the pause and play button (by the volume) UNLESS pop-up’s are allowed. If pop-ups are allowed, then I can interact with the pause/play function by clicking the video.

If I turn the shields off, the video runs but it has ads and pop-ups. I tried clearing the cache, cookies, history. I have no add-ons. I tried playing a video in both private and private with tor, same issue. I reset settings to default, no luck. I uninstalled and reinstalled, nothing. I closed all tabs and then closed the browser, opening it fresh, again, didn’t work.

I don’t know how this can be reproduced. Youtube appears to be working on everybody else’s computer but it seems like youtube is blocking specifically my brave browser’s shields. I think it’s reacting to Brave’s ad-block.

Version is: Version 1.26.74 Chromium: 91.0.4472.124 (Official Build) (64-bit)

Please help! I’m learning to code right now and absolutely require youtube to learn.

@Bigbob1989,
Thank you for reaching out.
Seems like a very strange issue. Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Sorry, I forgot to mention that I already tried that a couple days ago, then today tried it both on and off to no avail.

I just disabled ‘Trackers & ads blocking’ in the shields settings. The videos play with ads, but I hate ads and they’re unacceptable imo.

Are there any filters enabled in brave://adblock ?

1 Like

Yes, custom filters. I cleared them and youtube works again! Thank you so much for your suggestion!

I used block element on their “youtube Tv” pop-up about two months ago, it never caused an issue until now, oddly enough. I can’t thank you enough. I’ll recommend Brave to everyone even more than I already do.

3 Likes

Turning off custom filters in brave://adblock solved my issue as well. For your kind information, I am on Version 1.27.108 Chromium: 92.0.4515.107 (Official Build) (64-bit).
Thanks a lot everyone for your help.