Issues with sites loading slowly only on Brave

Still no solution. Every suggestion does not work. Brave loads webpages so slowly all of the sudden, for the past few weeks. Things told to try doesnt fix the issue. Only loads slow on Brave, other browsers site load quickly. Braves issue. Still no fix

Sample page to test against?

google.com i one page- especially when i have it set to " new tab" and “homepage”- i get the " page unresponsive" asking me to wait or close. This only happens with Brave, not Opera, Chrome, Firefox, nor Microsoft Edge

Hello @Doogie22

Thank you for reaching us and I’m sorry to hear you are going through this. One question, have you updated to the latest Brave version?

Be waiting for your response!

1 Like

Yes, as you read what i posted- Every suggestion does not work

1 Like

“upgrade connections to https” wasnt showing in my settings/shield - had to do this:

yet disabling that still didnt work- webpages load so slowly- 10+ seconds or more- even the Settings page takes long- i get the “page unresponsive” popup

However, the new ‘Upgrade connections to HTTPS’ setting in brave://settings/shields will only appear if chrome://flags/#https-by-default is set to ‘Enabled’. Setting it back to ‘Default’ will remove the ‘Upgrade connections to HTTPS’ setting in brave://settings/shields.

even the Settings page takes long- i get the “page unresponsive” popup

there are no “details” on the about brave section.
all it says is :
"Brave is up to date
Version 1.50.121 Chromium: 112.0.5615.138 (Official Build) (64-bit)"

Let’s start with this so we don’t give you a list of things you’ve tried. Can you give a list of all the suggestions you’ve attempted? I know I saw you mention about the toggle to HTTPS and checking that you’re using the most recent version. But what else? For example, have you tried:

  • Opening in Private Window and going to sites?

  • Creating a new browser profile and testing?

  • Completely disabling Shields?

  • Having Dev Tools open and checking for errors under Console?

  • Going to brave://settings/system and disabling Use hardware acceleration when available?

  • Adding content filters at brave://settings/shields/filters?

  • Disabling any firewalls (if any) you have on your device?

  • Installing Brave Beta or Brave Nightly to see if issue persists there?

Also, what OS are you using?

2 Likes

im using Windows 10.

i tried everything you listed except- Having Dev Tools open and checking for errors under Console

i dont know what tht is

@Mattches not sure what help can be provided, if any. Seems most things ruled out in terms of browser. I’m assuming Fanboynz was unable to replicate as also unable to do so. And for OP to say happens also on mew profile, testing on Nightly, etc then not sure what would make sense, if anything

There is an extension called Attitude, uninstall it and maybe your OS will find the proper way to troubleshoot and report some issues. :wink:

That was an indirect attack… and yes, it was a payback.
And if you prefer to ban me or flag constantly, just do it.
But this m.f until won t change his name here, will get the dirt, and everyone who offer the same.
If is indexed, is even better, like that people actually they can see with who are they dealing.
Mark my nick name.
Out forever.

@Michael-Alexander Not sure if trying to be funny with the “attitude” thing, but that’s violation where it said don’t attack tone. Currently you’re harassing them. I even moved their issue over to a new topic so it wouldn’t send you notifications and was hoping you’d leave it alone, as you were doing nothing but arguing and insulting on the other topic.

If you have nothing productive to add in resolving their actual issues (so only pertaining to pages loading slowly), then please leave it alone.

Thanks.

@Doogie22,
I’m sorry you’re having this issue. However, I want to ensure you’ve actually done the suggestions that @Saoiray and others have suggested. Not that I’m calling you a “liar” or anything.

I just ask this because if absolutely nothing is helping or making any difference in the behavior, then the issue may not be with Brave at all but rather your system and/or your connection (more likely your system). Especially since you’ve mentioned that Brave has only recently showing this behavior (meaning that previously it was working fine and that something, somewhere must have changed).

For example, if there was an issue with your current Brave profile (where all your browsing data is held), then creating a brand new test profile (and closing your original one while testing) would likely result in the browser running normally (not slow), as whatever data held in the profile is no longer affecting the load times.

The same could be said for Private windows to an extent. Further, if there was problem with your Brave installation itself, then downloading and using Brave Beta and Brave Nightly would prove this, as these install as fresh, separate browsers.

So I’d like you to please confirm that you’ve done the following:

  • Created a new profile with your current installation and browsed with it (ensuring that the original profile window is closed)
  • Tested browsing in a Private browsing window
  • Downloaded and installed Brave Beta and/or Nightly and testing browsing in them

If so, you’re saying that you saw no difference in behavior under any of those conditions — all the browsers/profiles/windows load just as slowly as they do/did when you opened this issue?

I did install Brave Nightly- the issue still existed.
I created a new profile, the issue still existed.
I did a test in a Private Window, the issue still exists.

The main problem is this. Under “settings/appearance”; i set my Home button/Homepage to “google.com”, when i click the home button, it takes 10+ seconds to load the google page. If its set to just “new tab”; it takes long as well, but not as often.

But in the settings/new tabe page, i have it set to “homepage”( which i have set to google.com)- it only sometimes takes long to open google. But when i have “new tab page” set to Dashboard, it loads quickly.

Maybe has something to do with google responding? Ive tried everything i can think of to check/fix this.

I also tried an extension for new tab page/homepage called Carettab- seems to load fine, but only occasionally slowly.

So maybe its my computer, but ive tried other browser- Chrome, Opera, Edge, Firefox- none seem to have this problem.

But i like Brave because thoseother browser sometimes crashes my computer when i play videos, Brave doesnt crash.

This is why i was looking for a solution, if i cant get a solution, ill just stick with the setting that although still slow, works the best for me.

Thanks for your time.

Hello,
Thank you for the information.
To be clear, all other sites are working fine? It’s just google.com/loading Google as your homepage that is the problem?

I have the same problem on the pc. When the page loads, the hard drive can be heard. Other browsers such as Vivaldi work well. I turned off everything possible. Photos load slowly.

I’ve been having this problem for almost 8 months now. The new tab and some pages will take over a minute, just hanging. If i open the app and try to quickly navigate to a webpage from a new tab (before the new tab fully loads), it will cancel the request and just load the new tab page. Sometimes the browser will tell me its unresponsive and ask if i want to wait or close the process.

This also seems to happen when trying to open the BAT rewards popout in the URL bar.

Apparently this issue has been around for awhile now, because i’ve seen posts dating back to june 2022 about this issue. Doesn’t matter the hardware (my laptop is a 4800h, 16gb ddr4 ram, 1660ti mobile while my desktop is a 5900x, 32gb ddr4, 6800xt). Both systems are running NVME drives, so its not an issue with the browser trying to cache data or load data from a traditional hdd. My network isn’t the issue either, as other browsers (edge, firefox) are lightning fast compared to this.

Steps i’ve already tried:

brave://net-internals/#sockets
-closing idle sockets
-flush socket pools
-reboot

brave://net-internals/#dns
-clear host cache
-reboot

brave://flags/
-disabling anything involving hardware acceleration for browser rendering
-reboot

nothing so far has worked.

It is a big pity that the problem is not being addressed. That’s why I switched from Firefox to Brave. If this does not change, I will be forced to use Vivaldi or another browser.

It doesn’t matter if it’s Google.com, when the browser opens it hangs. Google.com seems to hang even after the initial hanging, but the new tab page hangs before any other hangs happen.