How to disable forced transfer from http to https?

Description of the issue:
Since today Brave started to force my http requests into https after I have updated to the latest version.
If I post http://mywebsite.mycompany.com/ into the search area and click enter I get " This site can’t be reached" which was very strange to me. I quickly checked in Firefox and Chrome and everything seems to work just fine. Then I noticed that brave modified the address to: https://mywebsite.mycompany.com/ this is why it is failing as this is our internal website behind firewall we do not use https. I quickly check the settings if i have Upgrade connections to HTTPS is set to false and it is false. So not sure where this is coming from? Is there some new settings in the latest release or does Brave now automatically force all http into https without ability to cancel this behavior?

How can this issue be reproduced?

  1. Make sure my brave://settings/shields Upgrade connections to HTTPS is set to false.
  2. Post any http address in the search bar.
  3. Click enter.
  4. The address will change to https address.

Expected result:
The address remains http

Brave Version( check About Brave):
Version 1.25.73 Chromium: 91.0.4472.106 (Official Build) (64-bit)

Click on the brave logo & deactivate https.

Can you expand on what you mean? The Connection upgrade to https is already disabled as indicated in my post and seems to have no effect (see attached picture)

Oh I didn’t know these are the same settings.

Similar problem, one of the local site I am working on is always redirected to https.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.