Whatsapp Web is not working

Yes, it has been established that reinstalling/resetting (which adding a new profile mimics) works, the other 3 options don’t. I rather spend my time doing something productive rather than setting up my browser all over again, thanks.

WhatsApp Web is failing again, even after resetting setting to default. I thought the Brave developers were more aware of these posts. How unfortunate…please fix this. I really like Brave Browser, but this is very annoying.

1 Like

I am facing this issue for couple of days already. is brave addressing this now? currently am switching to chrome for whatsapp and brave for browsing which is annoying

1 Like

I’m having the same problem with whatsapp web[
Version 1.39.122 Chromium: 102.0.5005.115 (Official Build) (64-bit)
I always open WhatsApp web in a private browser. Because of this problem, I switched my browser to Opera. Please resolve this issue immediately. I found a temporary solution, The computer works after restarting after the DNS flushdns command, but we can not always do this.

Same here Whatsapp refuses to take responsibility for this.

1 Like

@johnanu

Did you also disable: ‘Use secure DNS’ (brave://settings/security)

Maybe . . .

An issue that might be summed up by one of the topic titles used:

You might try the fix, there, that applies to Windows OS users.

Whatsapp works fine in other browsers. The problem is Brave. I tried some possible solutions like disabling Secure DNS, enabling Javascript for Whatsapp, deleting browser data, restarting…nothing works.

3 Likes

@DanKo Using Honey extension?

2 Likes

Now I have problems on Facebook Messenger. It doesn’t load the chats, while other browsers do it without problems. Whatsapp still not working. Since the developers do not provide solutions, I’ll switch to Edge.

Disabling honey extension worked for me.
THX.

thank you for your details, i tried this also same result please find the screenshot attachments. Now im using opera private browser its working fine with me no issues.

Screenshot_2

I’m facing this issue too. I can’t connect to whatsapp web anymore with Brave, while other browsers (such as Chrome) work perfectly.

1 Like

Same problem here. I haved made tests with a clean Brave instalation, it worked, but for some days and after this, the problem cames.
Tests with Secure DNS disabled and clean history don’t worked for me…
Tested in Windows 10 (New Machine and clean OS instalation) and other Windows Devices…

1 Like

Yes, this is a real problem…which has not been resolved by the developers after 2 weeks since I created this post. I find it a shame. I have switched to Edge.

2 Likes

Let’s maintain this topic alive until they resolve this issue or argument any news about this problem. :fist_right:t3:

2 Likes

After reviewing several reports re WhatsApp connection troubles:

A WhatsApp connection using Brave Browser for desktop and laptop machines, to:

  • https://web.whatsapp.com/

means that you are also, somehow connecting to FaceBook. In a Brave Browser > New Window, go to: brave://settings/socialBlocking . . . and ‘Allow Facebook logins and embedded posts’.

A screenshot created on my iPhone, while I took a look at the WhatsApp app at Apple’s App Store:

That information - indicating that WhatsApp requires you to give up info about you, your computing behavior, and your computing devices - means that there are some Brave Browser settings that might need to be relaxed.

Some users of WhatsApp, have fixed their WhatsApp connection issue, by completely Resetting their Brave Browser > Settings. Ref. to an earlier reply, herein: ‘Whatsapp Web is not working - #15 by Ath3lstan’ (includes a screenshot).

Adjust Brave Browser Settings, Clear Cache, Cookies, History, etc., Flush socket pools

You might wish to be more selective, and thus . . .

In a Brave Browser > New Window, go to:

  • brave://settings/content/siteDetails?site=https%3A%2F%2Fweb.whatsapp.com

There, you might find some settings that are different than, but you can now adjust them to, the default settings for a new Profile:

  • Autoplay: Allow
  • Ethereum: Ask
  • Location: Ask
  • Camera: Ask
  • Microphone: Ask
  • Motion sensors: Block
  • Notifications: Ask
  • JavaScript: Allow
  • Images: Allow
  • Pop-ups and redirects: Block
  • Ads: Block (Block if site shows intrusive or misleading ads)
  • Background sync: Block
  • Sound: Automatic
  • Automatic downloads: Ask
  • MIDI devices: Ask
  • USB devices: Ask
  • Serial ports: Ask
  • File editing: Ask
  • HID devices: Ask
  • Clipboard: Ask
  • Payment handlers: Allow
  • Insecure content: Block
  • Augumented reality: Ask
  • Virtual reality: Ask
  • Window placement: Ask
  • Fonts: Ask

Next, in a Brave Browser > New Window, go to: brave://settings/clearBrowserData

For tab Advanced - set the following two particular items to:

  • Time range:All time
  • ENABLE: Hosted app data

Click on the ‘Clear data’ button.

Return to: brave://settings/clearBrowserData

For tab Advanced - new Profile defaults are set to:

  • Time range:All time
  • Enable: Browsing history
  • Enable: Download history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files
  • DISABLE: Passwords and other sign-in data (When Enabled DELETES PASSWORDS)
  • DISABLE: Autofill form data
  • DISABLE: Site and Shields Settings (When Enabled DELETES Shields Settings and RESTORES default: Shields UP for site-specific Shields [Lion icon] panel)
  • DISABLE: Hosted app data

Click on the ‘Clear data’ button.

(The ‘Clear data’ button also saves the selections.)

Return to: brave://settings/clearBrowserData

In case you wondered . . .

For tab On exit - the new Profile defaults are:

  • DISABLE: Browsing history
  • DISABLE: Download history
  • DISABLE: Cookies and other site data (Signs you out of most sites)
  • DISABLE: Cached images and files
  • DISABLE: Passwords and other sign-in data (When Enabled DELETES PASSWORDS)
  • DISABLE: Autofill form data
  • DISABLE: Site and Shields Settings (When Enabled DELETES Shields Settings and RESTORES default: Shields UP for site-specific Shields [Lion icon] panel)
  • DISABLE: Hosted app data

Next, in a Brave Browser > New Window, go to: brave://settings/security and set:

  • DISABLE: Always use secure connections (‘HTTPS Only’ toggle switch.)
  • DISABLE: Use secure DNS

Next, in a Brave Browser > New Window, go to the Global Shields settings: brave://settings/shields and set:

  • DISABLE: Auto-redirect AMP pages
  • DISABLE: Prevent sites from fingerprinting me based upon my language preferences. (I have found, that DISABLE is necessary for some websites.)

Next, are the new Profile default Global Shields settings for the remaining items. For connecting to WhatsApp, you might temporarily set, to:

  • Trackers & ads blocking: Standard
  • Upgrade connections to HTTPS: Enable (‘HTTPS Everywhere’ toggle switch)
  • Block scripts: DISABLE
  • Block fingerprinting: Standard
  • Block cookies: Only cross-site

I say ‘temporarily’, because I favor the ‘Aggressive’ / ‘Strict’ settings, and usually, only relax these settings for difficult Sign-In connections.

Cookies check

In a Brave Browser > New Window, go to: brave://settings/cookies and in the upper-right area of the window, enter into the Search field: whatsapp

Then, search down the cookies settings page and check to see if whatsapp shows under Sites that can never use cookies . If exists, then remove the whatsapp entry.

JavaScripts check

In a Brave Browser > New Window, go to: brave://settings/content/javascript and in the upper-right area of the window, enter into the Search field: whatsapp

Then, search down the javascripts settings page and check to see if whatsapp shows under Not allowed to use javascript. If exists, then remove the whatsapp entry.

Clearing DNS cache

Option A

In a Brave Browser > New Window, go to brave://net-internals/#dns and click on ‘Clear host cache’

Next, go to: brave://net-internals/#sockets and click on both of the following (in succession):

  • Close idle sockets
  • Flush socket pools

Exit / Quit Brave Browser

Exit / Quit everything else and Restart your computer.

Option B

How to flush DNS cache in Windows OS: ‘https://www.wikihow.com/Flush-DNS

How to flush DNS cache in Mac OS: In a Terminal.app window, enter at the prompt:

  • dscacheutil -flushcache

Notes re what are:

DNS cache:

Socket pool:

‘With pooling, instead of closing a connection after it is used, we can keep it idle while it waits to handle another request. This saves the resources required to create a new connection.’

For clarity of what are:

  • HTTPS Everywhere (‘Upgrade connections to HTTPS’ toggle switch at: brave://settings/shields)

  • HTTPS Only (‘Always use secure connections’ toggle switch at: brave://settings/security)

Ref., see:

1 Like

The problem is still unresolved by Braff
It is essential
We can go back to Chrome or Firefox and let Brave tean mess around :face_with_symbols_over_mouth: :rage: :rage: :rage:

3 Likes

No I’m not using honey extention

yes you are right me switch to opera

1 Like

From Firefox: https://old.reddit.com/r/firefox/comments/vg3886/whatsapp_web_not_working_on_firefox_developer/