WhatsApp can't login after scanning the QR code

Description of the issue:

WhatsApp can’t login after scanning the QR code.

Steps to Reproduce:

  1. Open web.whatsapp.com
  2. Scan the QR code on the app
  3. Wait to return an error similar to “please check your device has an active internet connection”

Actual Result:

It doesn’t log in, and returns with an error. Sometimes I can’t even get to step 2 as the QR code loading animation keeps running indefinitely.

Expected result:

It should log me in properly, and start using it.

Reproduces how often:

100% of the time.

Operating System and Brave Version:

OS: Windows 11 Pro Version 10.0.22000 Build 22000
Brave version ( desktop ): Version 1.39.122 Chromium: 102.0.5005.115 (Official Build) (64-bit)
Mobile OS where whatsapp is installed: Android 12

Additional Information:

I tried reinstalling Brave ( after completely removing every each folder of it, searching for any remnants after uninstalling ), reinstalled WhatsApp on android, cleared cookies completely, disabled Shields, and same thing happen. NOTE: This does not happen on WhatsApp desktop, or Edge browser, as I tested there as well.

1 Like


Worth reading:

Whatsapp Web is not working - #15 by Ath3lstan

Thank you, but well, how could resetting help, when I just reinstalled everything? And other info is not helpful at all unfortunately.


A screenshot created on my iPhone, while I took a look at the WhatsApp app at Apple’s App Store:

That information - indicating that WhatsApp requires you to give up info about you, your computing behavior, and your computing devices - means that there are some Brave Browser settings that might need to be relaxed.

In a Brave Browser > New Window, go to:

  • brave://settings/content/siteDetails?site=https%3A%2F%2Fweb.whatsapp.com

But, you certainly can test settings, to see what might ‘grant’ you success, trying to solve your issue(s) with WhatsApp.

Certainly, you need to Allow JavaScript for:

  • https://web.whatsapp.com/

Re the Brave Browser > site-specific Shields (Lion icon - right end of the browser window’s URL address field) panel selections . . .

If you choose to relax the

  • Tracking and Ads
  • Fingerprinting

settings, I suggest you do that, one level at-a-time. In other words, inch your way along, with all settings adjustments, and test. No giant leaps in settings changes - when relaxing settings.

Examine your cache, cookies, and site data clearing - SETTINGS - at:

  • brave://settings/clearBrowserData

for all three tabs: Basic / Advanced / On exit

in order to be more certain, that you are more accurately clearing what needs to be cleared.

Again, thank you very much for the info provided, but step 2 and step 3 will NOT help, as I stated that I already tried disabling the shields completely, and I also removed the cookies together with reinstallation of the whole brave app.

On step 1, I allowed everything just to be sure, and again, it did not fix anything.

1 Like

hello , I’ve been having the same issue too for about 3 days for now , so did you get any solution yet ???

Hey, this is recent to me too, but no, no fix yet. Hopefully someone official will acknowledge this issue once and for all, and fix it.

1 Like

you know what’s quite strange … mostly apps acts with Brave as if its chrome , which is obviously they’re the same with improved features (mostly ad blocking) , although I still can login to WhatsApp web through chrome , which is quite strange for me .
I really hope the can fix this issue soon cause I really loved Brave and it did helped me alot … thanx for responding I’d politely ask you to notify me if you found any some thing about this issue and thanx :heart::heart::heart:

@sezbulent , @fanboynz (Brave Support)


Using your Step 1: ‘web.whatsapp.com’ as a link, and using Brave Browser for Mac (v1.39.122) (and Shields v1), I right-clicked on that link and chose to go to a New Private Window . . .

Where I right-clicked on the triangle icon at the left end of the URL address field. Getting a pop-down menu, where I Enabled: JavaScript for the site:

There was something of a partial refresh of the page, resulting with a prompt to Reload:

I clicked on the Reload button, and the result (including a locked padlock icon - that replaced the former alert triangle icon):

At SSLLabs.com . . .

I checked ‘web.whatsapp.com’ with good result:


And I checked ‘whatsapp.com’ with an undetermined result:


@sezbulent - if you can get a screenshot of the ‘loading animation’ that may help:

@fanboynz , OP (sezbulent) reports: ‘Sometimes I can’t even get to step 2 as the QR code loading animation keeps running indefinitely.’

Related: ‘Whatsapp Web is not working

http://web.whatsapp.com/ shows as unsecure in Chome also?

  • Disable all extensions, restart browser, retest
  • If you have any firewall/antivirus software temp disable also, reenable if it doesn’t help

didnt work bro :sweat::sweat::sweat:

@289wk @fanboynz I literally said in the beginning and along the posts, that I reset everything, enabled everything for web.whatsapp.com, reinstalled everything, and that it works on other browsers, I don’t want to be disrespectful, but you keep telling me over and over to do the same things that I’ve said I’ve done.

Using Honey extension? @sezbulent

1 Like

no the only extension i use in brave is IDM

No, I do not use Honey extension.

Does disabling all the extensions, then restarting brave, help, ? (just an idea)

Ok, something is really weird. Considering I reset the browser and it still didn’t work, I now again, disabled all my extensions and tried to log in, resulting in a successful attempt.

Here are the extensions that I’m using, and if I was to guess ( just lazy right now to test which one is the problem ), I would say the problem might be from the “Autoscroll” extension, as this is the last one recently installed. ( the other ones I’ve been using for quite a while now, so idk if might be from another extension, unless they’ve been updated ):

What is odd though, is that I use the same brave browser with the same extensions and everything ( as it is in sync with this one from the Windows machine ) on a linux machine ( Arch - Manjaro XFCE ), and I did not encounter the issue there.

tried this but did not help

Which extensions do you have installed?

duckduckgo and grammarly