Wallet does not let me confirm transaction

Description of the issue:

Are you using the (new) Brave Wallet or the (old) Crypto wallets implementation?
new Brave Wallet

How can this issue be reproduced?
Connect wallet to dapp, attempt to make transaction**

Brave Version (check About Brave):
Desktop v1.46.153

Additional Information:

Whenever I try to make a transaction with ETH the “Confirm” button in wallet stays grayed out and I am unable to confirm the transaction. The numbers for amount of ETH and gas fees have no decimal points and thus are WAAAAY larger than they should be (which may be why I can’t click confirm). This happens for any Dapp that I connect to Brave wallet. See included screenshots for example of issue and wallet settings.

Example of issue

Wallet settings

ETH network setting

Hi @paullikethesaint,

I tried interacting with some dapps and was unable to replicate this issue. I noticed from your screenshot that a RPC url does not seem to be selected. Could you try selecting the a rpc url and trying again?

If that doesn’t work, you could try resetting the network if you have the option available.

If the above fails to fix the issue, a more drastic option to try would be to backup your seed phrase and private keys, reset Brave wallet, then import your seed and keys.

Thank you. I backed up and restored the wallet and it seems to be working now.

1 Like