Very weird Brave behaviour

Description of the issue:

Whenever I search for anything, brave doesn’t remember any search settings done previously.

When you search with google search, there is a cogwheel on the right that allows you to change your region, dark mode, language and more. Whenever I make a new search, these settings are completely wiped.

This makes brave unusable, as it happens with any search engine, the dark mode is never on this way and I have to click whether I want my native language or English.

I have tried restarting my computer, clearing any brave data and even reinstalling brave. Also this doesn’t happen with any other browser.

This happened suddenly today with no apparent reason.

Brave Version( check About Brave):

Version 1.66.115 Chromium: 125.0.6422.112 (Official Build) (64-bit)

3 Likes

Having the same issue here. I just reported this issue Today here. It seems to be related to Brave Shields, since the issue doesn’t occur when Shields are completely off.

1 Like

Still not solved. Turning shields off doesn’t work either.

@Memory places like Brave Search save your settings in cookies. Google often will save settings in your account, but I’m not sure if you’re signed in to a Google account? If not, I believe they fall back to relying on cookies to store your settings.

So if you do have anything like your dark mode or all and then you have anything clearing cookies (browsing data), you would lose your selections and have to do it again each time.

Obviously things like clearing data, reinstalling, etc would not be a solution. In fact, those would be some of the direct causes of your problem. Do you have anything set to clear cookies or anything on exit?

1 Like

No, I don’t have any settings that on that clears data on exist, this also happens on mobile Brave. And yes I am logged in, but it happens when It happens no matter if I am logged in or not.

Now, sometimes it works and sometimes it starts to clear the search data again. One thing that it never keeps is the region, no matter where I change it to, it automatically changes to default region.

I am pretty sure It isn’t anything I’ve done on my side since I remember it happening suddenly and also the confirmation that this happens to other people as well.

Also, a confirmation that this is a Brave specific issue is due to the fact that other browsers work just fine.

I was trying to report the same problem affecting Brave on my android phone that started precisely a week ago. My post got blocked by Brave’s Akismet. Today Firefox and Brave browsers on Win11 have the same problem.

So, there’s no solving for this one?

I have the exact same problem, on both mobile and desktop. It started a few weeks ago and is driving me nuts… I’m in switzerland, so it assumes I speak german (I don’t) and switches to it all the time. What’s crazy is that I’m logged in my goggle account, which has my settings (english, dark theme, etc) Whenever this happens, if I check on my avatar on the upper right screen of the google page, I can see my settings set to german, light mode etc. I need to reload the page and voila, it reverts back to my normal settings.

This is happening to two other friends of mine. Perhaps someone could look into this over at brave?

I’ll have to ask the team about this. If it was just desktop I’d probably say an extension of some kind was causing it but there seem to be enough reports of this/mobile reports that that is clearly not the case.

That said, I cannot reproduce this on Windows or macOS — Google settings are retained after a search and this applies to any/all search engines I use.

Hope to have more information soon.

The problem is still occuring… No sign of brave support anywhere. That’s very reassuring

2 Likes

Can confirm, still having this issue.

The issue disappeared for me today. The only thing I had done on my end was briefly enable Send a “Do Not Track” request with your browsing traffic in brave://settings/privacy, then immediately disable it (I didn’t even use the browser in-between that time). Try your luck with this setting.

Never mind, it started happening again, and more often now.

Ok, this is truly driving me mad to the point where, after years of use, I’m firmly starting to search for an alternative browser. The fact that Brave doesn’t give an excrement about this issue, won’t even acknowledge the problem, let alone answer the bloody question or propose a solution, makes me furious. It’s been almost two months now!!

1 Like

I feel you, I am also losing my mind over here.

They sort of acknowledged the issue here and in another thread (Shields are causing Google Search to reset display language & theme settings randomly - #16 by fanboynz), yet ignored it in a couple of others.

They need to do something soon or I’ll also be switching browsers.

1 Like

Given the backlash, surely this will get solved at one moment. If I had to guess, they are working to find the issue, so I don’t really think they’re intentionally ignoring this.

Nonetheless this is taking a hell lot of time that’s for sure. Are there literally 0 updates about this issue?

I’m ensuring that we have an open issue for this now. But before I do, can anyone here still encountering this issue confirm whether or not they see this behavior in other browsers? Ideally, this would be tested in another browser that is Chromium based.

Additionally, testing this behavior in Brave Beta would also be very useful (note that the Beta will install as a separate browser and not overwrite anything on your current installation).

Thank you

Hi. I also use Firefox from time to time—which is not chromium based, but I’ll mention it anyway—and haven’t seen this issue yet.

Before I try beta, can you explain why would that be different? Are newer unreleased versions addressing this?

Beta has the fixes and Chromium updates that will be going into the stable/release build during the next update. Seeing if the issue persists in Beta may help us determine if the issue is specific to Brave or specific to your Brave profile/user data.