No dark mode in Brave search

EDIT: found an answer myself. See first reply.

original post:

Description of the issue:
I’ve just changed my search engine to Brave, and have dark mode ON in settings. Brave search results are not in dark mode, ie white background.

Previous search engine was Duckduckgo - dark mode worked with it as expected.

How can this issue be reproduced?

  1. Enable dark mode in browser settings
  2. Set search engine to Brave in browser settings
  3. Search for something!

Expected result:
Expect to see search results page in dark mode

Brave Version( check About Brave):
Version 1.34.80 Chromium: 97.0.4692.71 (Official Build) (64-bit)

Additional Information:
Tried closing & restarting the browser, no change.

1 Like

Answer: the Brave search web page ( or any search results page) has its own settings (cog icon, top-right), containing its own dark mode switch. I guess this is as intended: use the website’s settings; Brave browser’s global dark mode setting doesn’t apply. The same is true for this community website. A bit counter-intuitive IMO, but there you go.

Will leave this here in case someone has the same question.

1 Like

You can use an extension from chrome web store to force dark mode on all pages, like Dark Reader.
Or there is a hidden flag in chromium which can force dark mode on all pages without an extension. But, the extension is better than flag.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.