Brave Browser constantly switches to Russian

Description of the issue:
Brave constantly switches to Russian for search results
Set google account to English (it already said english, russian was not listed)
Updated Brave (many times, this is a constant issue)
It does not happen when using standard chrome

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Just browse for an hour after going back into google account and resetting from english to english
sometimes fixes it for an hour. Like I said plain chrome works.

Actual Result (gifs and screenshots are welcome!):
No improvement, after setting

Expected result:
english results

Reproduces how often:
every day

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 home
Version 1.12.114 Chromium: 84.0.4147.135 (Official Build) (64-bit)
Additional Information:

could this be related to extensions? the only one installed is ‘PDF JS’. I am pretty sure I experienced this before installing the plugin.

I also run brave on a macbook pro and never experience this on it

I do see an old post here with no reponses from someone that had the exact same issue.

Hello @IBB

could you clear your cache and disable all extension then restart you browser and see if that help

have a nice day :slight_smile: