Shields are causing Google Search to reset display language & theme settings randomly

Description of the issue:
After 3 to 4 Google searches, the display language resets to the language Google detects from my region (I’m from Saudi Arabia, so it resets to Arabic when I have it set to English). This doesn’t happen when Shields are completely off. I tried turning off all of the filters I have enabled and still encountering the same issue. Sometimes it even resets my theme settings (I have it set to Light mode but it resets back to Dark).

Exact URL of the website in question:

Screenshot of the ad as it appears in Brave:
Not an ad issue.
Did the issue present with default Shields settings? (yes/no) yes

These are the settings I use.

I tried changing Block third-party cookies to Allow all cookies, and still same issue.

Does the site function as expected when Shields are turned off? Yes, I even tried different browsers and don’t encounter the same issue.

Does the issue occur when using a Private window as well? (yes/no) Yes, the Issue does happen in a Private window.

What OS are you using when you see the issue? Windows

Brave version (check About Brave): Version 1.66.115 Chromium: 125.0.6422.112 (Official Build) (64-bit)

2 Likes

Also resets the theme back to white.

1 Like

same here. must be an “anti fingerprint” filter causing this

Same here both on iphone and pc.

1 Like

+1 Happening for me as well, I’m on PC

1 Like

I have the same problem too

1 Like

I switched it off but still the same problem. But when I switch Shields off it turns back normal

1 Like

Still having this problem, turning shields off doesn’t seem to work anymore

1 Like

Still happening @Dhia @Memory ?

Yes. It still happens

Also, I have an unrelated problem, but there doesn’t seem to be any contact button to solve this one. I have a post (about another issue) that’s been pending for the last 3-4 days, which I assume is due to the fact that I’ve attached images. Is it normal to take this long?

@fanboynz Still happens here with Shields on, yesterday (after you had posted) it happened with them off.

Can I have exact steps to repro the issue?

@fanboynz It doesn’t seem to happen randomly to me anymore (for the last 2-3 days, maybe 4), but only after booting up Windows 10? Also when I wake it from Sleep mode. The first search (through the address bar, Google set as the default search engine) will reset the theme and the region setting to “Current region”. If I refresh, the theme will go back to dark, but the reset region setting remains. I can’t force the issue afterwards in any other way now.

Neither extensions or Shields seem to be impacting this. I have “Improve search suggestions” on in Brave, and other settings are default except for a couple of things that shouldn’t impact how Brave connects to any server.
I doubt the search suggestion option being on is the culprit, because it’s disabled in Private mode and the issue would still happen in Private Windows (haven’t checked it yet since this recent twist).

All good, lets hope it was just some small random glitch. Let me know if happens again and its easily reproducible…

Sorry, I should have check this right away: it actually happens whenever I search for the first time after opening the browser! Brave has to be shut down completely before that, that is, as it happens neither with a new tab or a new window. So it’s very easy to reproduce for me.

I’ll try figuring out the cause later. Is there something you’d suggest?

No, it still happens for me.

I am not sure what steps there are to replicate. I’ve mentioned everything that I could here: Very weird Brave behaviour.

It seems to be very random in nature. Sometimes it happens for many hours on and and sometimes it doesn’t happen at all. And as I’ve mentioned in my post, it happens on my phone’s brave too, so extensions are instantly ruled out.

Perhaps it’s a regional issue? Internet? I’ve got no idea, but other people that I know and use Brave don’t report this.