Vertical tab bar opens to full width every time I come back to a full-screen Brave window

Description of the issue:
Ever since the “fix” that ensured the collapsed vertical tab bar would be completely hidden upon switching to full-screen and restored when exiting full-screen mode, the bar has been fully expanding when coming back to the Brave window (after having accessed another window, whether Brave or not) even when the mouse pointer is nowhere near the edge of the screen. In this situation, the tab bar should remain completely hidden. The fact that it not only re-appears but expands to its full width is particularly annoying. You have to move the pointer to that edge and then away from it for the bar to disappear.

How can this issue be reproduced?

  1. (If not already set.) Enable vertical tab bar:
    Settings | Appearance | Tabs
    Enable Use vertical tabs
    Enable Expand vertical tabs panel on mouseover when collapsed

  2. Access any website, or even brave://settings, or any page therein.

  3. Press F11 to activate full-screen mode. Notice that the tab bar gets completely hidden.
    If, on the contrary, the bar expands at this stage (which does not seem to happen consistently), move the pointer over and then away from it to get it hidden.

  4. Switch to another window. (e.g. Alt+tab) If using a mouse or touchpad, be careful not to bring the pointer near the applicable (left or right) edge of the screen.

  5. Come back the the Brave window. Notice that the tab bar is not only present but expanded.

Expected result:
In full-screen mode, hidden vertical tab bar should remain hidden.

Brave Version:

[Edit] Since posting the above I’ve discovered that, upon switching to full-screen mode, the vertical tab bar also – sometimes – expands instead of hiding.

[Edit 2] This bug is still present in 1.65.114.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.