Urls starting with file:// wont enable scripts

Hi,

I have Script Blocking enabled in main settings, but having an issue with file:// paths.

Im developing some html in a standalone html file on a url like:
file://fsrv/company/Development/Projects/Title/dev1.html

The site shows the little </> script disabled icon (brave icon is greyed out as it is a protected url).

If i click the script icon and hit “always allow javascript on blah”, it seems to have no effect.

If I check the settings from the “Manage” button, it is indeed set to allowed, but the scripts still dont run and the icon remains in the address bar.

How am I supposed to use brave to develop code on a local resource if I cant enable script for that individual path? or even ALL file:// paths? without enabling it system wide.

The only way to resolve it seems to be disabling browser wide script blocking, then file:// paths allow script, but then so does every other website. literally the opposite of what I want to happen.

HALP!