Unable to upgrade to new brave wallet

Description of the issue:
When I attempt to migrate to the new brave wallet, the browser crashes after I select import from existing wallet and enter my wallet password. Upon re-starting Brave, I attempt to enter my wallet password, but recieve a message that says something to the effect “The mnemonic being imported is not valid for Brave Wallet”.

How can this issue be reproduced?
If I switch back to the classic crypto wallets depricated, everything returns as it was and I can access my wallet. If I attempt to import and upgrade to the new brave wallet, the issue commences after entering the wallet password in the import process.

Brave Version (check About Brave): Version 1.32.113 Chromium: 96.0.4664.45 (Official Build) (64-bit)

Additional Information: My brave wallet has two accounts, one account is a Trust wallet address, and the other I believe is a default brave wallet account that I do not use. I also use multiple networks.

Would you be able to send us a crash ID in brave://crashes after you reproduce it again?

You can also use this when starting Brave if you don’t mind to give us more information. Please be sure to make sure there’s no private information in the log though before sending it.
--vmodule=brave_wallet_service_delegate_impl=3 --enable-logging=stderr

You can send to anthony@brave.com and reference this community post URL too.

I am having the same issue. Was a solution ever discovered?

We have some refactoring for the import process but not until 1.35.x which is ~Feb 1st. Could you setup via restoring your recovery phrase instead?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.