Unable to turn on Twitter browser push notifications

Hi, would love to be able to receive push notifications for Twitter as I browse it pretty often on Brave browser. However, I get an error message saying “Unsupported browser. It looks like your browser doesn’t support push notifications.”

Is this a known issue or is there a work around to enable the push notifications?

Many thanks in advance. Cheers!

@0xbendito Please respond with the following:

  1. What type of device are you using?

  2. What OS are you using? (For example, if Android, is it Android 9, 10, or what?

  3. What version of Brave? (don’t say “Latest,” please advise the specific version number)

  4. Does turning Shields off make a difference?

  5. If you’re on something like a Desktop version, do you have any extensions? If so, try disabling them and/or opening in a Private Window.

Hey, please see replies to the questions you suggested below.

  1. What type of device are you using?
    Lenovo ideapad 720S-15IKB, Intel(R) Core™ i7-7700HQ CPU @ 2.80GHz 2.81 GHz, 16.0 GB (15.6 GB usable)

  2. What OS are you using? (For example, if Android, is it Android 9, 10, or what?
    Windows 11

  3. What version of Brave? (don’t say “Latest,” please advise the specific version number)
    Version 1.43.93 Chromium: 105.0.5195.127 (Official Build) (64-bit)

  4. Does turning Shields off make a difference?
    No, I have tried turning shields off, and resetting cookies and site permissions.

  5. If you’re on something like a Desktop version, do you have any extensions? If so, try disabling them and/or opening in a Private Window.
    I have also tried turning off all extensions in normal and private browsing window. However, the issue still persists.

Appreciate any help on this issue. Thanks!

Can you also make sure to check brave://settings/content/notifications to make sure enabled Sites can ask to send notifications

Plus make sure Twitter not listed under Not allowed to send notifications

Yup, https://twitter.com:443 is listed under the allowed to send notifications section after I allowed it from the pop up which appeared when I first tried to turn on notifications.

I’ve seen previous posts about this issue. Was wondering if there was a fix for it.

I don’t recall anything quite pertaining to the situation that you’re explaining. But then again, it’s not like I’m going to be able to see and respond to every single topic or post either.

I do know that with this being the weekend the likelihood of anyone from Brave seeing this and responding before Monday is slim because they tend to work just Monday through Friday. that is unless one of the new people is going to be working on the weekends.

Brave, within itself is able to handle notifications with no problem and I narrow down them on the basics for the browser in case it was settings there. The next thing I would’ve said is to double check your Windows notifications settings. It is possible that you have prevented or limited notifications from Brave and that would be causing Twitter to show the conflict. I don’t know if you’re getting notifications from Brave from anywhere else? But if you go to your Windows notification center and then look for Brave and see if you got them turned on.

I’m actually responding really quick on voice to text from my phone as I’m getting ready to head to bed for the night. I’ll try to check in on this tomorrow and see if I can find any other similar issues on Brave community or anywhere on the Internet that might help to find a solution.

Posting two older topics that are related. Also posting a solution from the related Brave GitHub issue report that is still open and from one of the older topics. Many of the topics posted in the past reporting this issue were closed without a response.

Solutions:

Brave GitHub issue report
windows 10 desktop, all notifications still not working in brave browser #3235

mattspew commented Mar 31, 2021
Have you checked the system notification setting for Brave app?

Thought I add my two cents here after fixing my Brave notification issue.

I also had not been getting any desktop notifications and tried everything Brave related to fix it without success.

After reading this thread and this reply I decided to check my Windows 10 settings and it is now fixed. Nothing I’d read before prompted me to think it was a Windows setting.

Windows → Settings → System → Notifications & Actions → Turn on “Get Notifications from apps and other senders”.

I then used the the following website to test notification: https://web-push-book.gauntface.com/demos/notification-examples/

Community topic

Related topics with responses:

Topic below has additional troubleshooting steps you could try if neither of the above solutions work for you.

Hope this helps. Take care.

Edit: Found another GitHub issue report still open and with recent posts. You may want to read the comments which may help troubleshoot your issue.

Found this interesting and wondering if it relates in some way:

setting Use Google Services for Push Messaging to on made the Google Drive notification setting able to turn on.

Also from another topic, which seems a strange workaround…