Push notifications stop being pushed after a while

It goes like this: it works flawlessly for few days and then suddenly one day as the pc boots up and brave is active in the tray, nothing gets pushed through. Then I would open the browser but still nothing, and only when I open one of the websites, which are allowed and should notify all the time, then the banner shows up.
I tried other chromium based browsers(Edge, Chrome, Vivaldi) with exactly the same addons installed and none of them would have that problem.
It’s tiresome keep reinstalling brave. Can anyone tell me what is going on pls! Thx!
I’m on Win10, everything is updated.

same problem. notifications stops for no reasons and I disnt change anything. Im on windows 11

Don’t know if this will help or not or even if it is related. Just putting it out there. :stuck_out_tongue:

Thank you for reaching out but we’ll need a lot more information surrounding this issue before we can start troubleshooting. To start, it’s unclear whether or not we are talking about Brave Ads notifications or if you’re referring to website notifications from valid sites such as Youtube, gmail, etc.

Also what version of the browser are you using? Can you be more specific about which websites work vs which sites don’t work?

I’m using the latest version to date: 1.36.116, and the problem still persists.
It’s the regular push notifications, which need to be ‘awaken’ by visiting the website in order to start working. Once that’s done they push through normally, until the next reboot or shut down. Starting the browser closed to tray doesn’t help too. It needs to be done manually every first time. So, it’s an annoying routine.
I’m talking about twitter, youtube, odysee, etc. I guess it’s because they use google push messaging and you have problems with said company:) but, at least tell us it’s official policy so we can switch it off permanently and never bother with it again.

So after granting permission to the website to display notifications, these permissions get reset once the browser is closed?

Can you check and see if you have any data set to be cleared "on exit (Settings --> History --> Clear browsing data --> [On exit])?

No, the permissions don’t get reset. Nothing gets cleared on exit.

It goes like this:
I start my PC → Brave starts in the tray(I use extension for that) → no push notifications pop up from the site X. Nothing! Then I go to the site X and THEN they all start to pop up! As if visiting the site wakes up the browser to it’s normal functionality. Then all is fine until next PC reboot (or manually force-closing the browser). Rinse and repeat.

Even if I set Brave to start with windows (shell:startup shortcut) - same thing - no notification pops up until I manually open the site! And it’s the same for the notifications here, on Brave community - nothing notifies until I open it!

I suspect that the extensions you have installed in the browser may be causing a conflict here. Can you try creating a new temporary browser profile and testing the behavior there to see if you get the same results?

To test if your Windows settings are set correctly to accept notifications there is a useful test for this.

Tried that, same story; then reinstalled everything clean - nope. Notifications just wouldn’t start pushing until the site is visited.

Thank you for testing. I’m doing a little more digging — will reply back here when I have more information.

bumpty, bumpity, bump.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.