Unable to activate browser-notifications

I’m unable to activate browser-notifications on various sites. Here Twitter goes as an example.

How can this issue be reproduced?

  1. Login on the Twitter homepage
  2. Goto settings > notification-settings and try to enable push-notifications
  3. hit the button (images below) and nothing happens.

1.1

2.1

3.1

Expected result: enabled push-notifications for Twitter

Brave Version( check About Brave): Version 1.0.0 Chromium: 78.0.3904.97 (Offizieller Build) (64-Bit)

OS: macOS Catalina 10.15.1 (19B88)

Additional Information: I use other sites that provide browser-notifications and there it’s also not possible to successful enable notifications. I checked the Brave-Shields and disabled them one after the other to no avail. With all shields disabled I also won’t be able to enable browser-notifications in Brave.

Really absolutely strange: after updating Brave to Version Version 1.0.1 Chromium: 78.0.3904.108 (Offizieller Build) (64-Bit) I’m completely unable to enter the Twitter settings.

EDIT:

I think Twitter did something on their side and the webapp comes different now. Settings are in reach again but the main-issue is still actual - also on latest Brave version.

Super weird! I managed to reproduce this myself – it may indeed be on Twitter’s side. Will raise to the team and we’ll see if there’s anything we can fix on our side.

1 Like

Hi @Asad don’t think it’s Twitter to blame here, it works with the actual stable Chrome without an issue?

Thanks for investigating!

Regards,
thommes

Could be a webcompat problem. I’d try dropping Shields to see if that helps. :slight_smile:

EDIT: Looks like a fix is on the way for this one! https://github.com/brave/brave-browser/issues/3464

Thanks for the edit @Asad. I’ve tested all possible Shield configurations to no avail.