Unable to set homepage

I set my homepage to Start Page and clicking on the home button initially brings up that page. However, when I click on the home button again, it takes me to google.com, regardless of how I set my homepage in the settings.

@soofeenee can you provide more info about your issue?

Thanks

I have used Firefox with google.com as my homepage for a number of years. Concerned about privacy and tracking, I switched to Brave. I love it, but no matter how many times I set startpage.com as my homepage, the browser keeps sending me back to google.com. I have changed the setting as you can see by the attachment, and the Google site shown is what I get when I click on the home button. I’ve done everything I know to do, but I still get directed to the very site I’m trying to avoid.

1.png

Thanks for the screenshot @soofeenee.

In short, there’s 2 different settings. The one that you set above is for “On startup”. So, whenever you open Brave, Brave will open that page.

For home button, you should set it under

Settings > Appearance > Enable “Show home button” > And set to your preferred page.

Hope that can help.
Thanks.

Thank you so much for your response. I kept working at it and just figured out the information you just provided. Everything is set now and it works like a charm. Thanks again!

2 Likes