Unable to reconnect Gemini wallet to Brave rewards

Hi, my Gemini wallet disconnected itself from my Brave rewards. In place of the ‘Verify Wallet’ option it said ‘Disconnected’. I tried to verify it again but it failed. I tried a few times with no luck. There was an option that seemed to release the Gemini wallet from Brave completely, so I tried to do that and reconnect my Gemini wallet from scratch, but it just won’t connect. It just keeps saying “Sorry there was a problem processing your request, please try again.”

Anyone got any idea what’s going on?
Thanks

2 Likes

Is there any Brave support?

1 Like

Hi Snubnose77 and welcome

It’s busy around here with issues so I thought I might try and help! At least the following should be what happens in my experience.

Firstly the Gemini wallet is set (I think by default) to disconnect automatically as a security feature from the browser every couple of months so what you describe happening originally is not a problem as you should still receive the rewards to the wallet just you can’t see your wallet’s balance all the time.

Once disconnected all you should need to do to reconnect(in my experience) is go to the rewards page and then the rewards window should have a box which at the top of it says verify wallet - I know you have already verified it originally but that’s what you click on. Then click on the next window click continue then on the next window choose between Uphold and Gemini and that then takes you to a new page which is the page for logging into your Gemini account. Once you have logged in to your Gemini account you should find things are back on your new tab showing your Gemini Brave Reward balance.

If the above isn’t what happens you probably need someone from support to give you a helping hand, or a community member who knows more than little ole me :grinning:
Anyway hope the above does the trick, or helps you get some zzzz as it seems awful long now.
good luck

Hi, thanks! I’ve already done this though. It fails every time saying “Sorry there was a problem processing your request, please try again.”

ok
a couple of other things to check is that your running the most up to date brave browser but my guess is that’s not the issue.
By searching the community I see there was someone reporting a similar issue a while back https://community.brave.com/t/unable-to-link-brave-to-gemini/286481.
Might be worth DM one of the main support people I see @Mattches on the thread I mentioned, but there are others
Good luck and hope this helps

Yeah, I’m on the most recent version, but I’ll give mattches a try, though looking at the thread I’m not sure anyone actually got a reply in the end.
Thanks for your help!

1 Like

Does anyone know how to contact Brave support?

Hi, I am also having the exact same issue reported here as I am unable to get Gemini wallet reconnected to my Brave rewards after I switched to another device recently.

It just keeps saying “Sorry there was a problem processing your request, please try again.”

Anyone got any idea what’s going on?
Thanks

1 Like

The same problem here.

1 Like

Yes, I also keep getting the same messages after encountering the same problem.

1 Like

Yes, I also get excatly the same issue. Both windows 11 and MacOS cannot connect to Gemini. Also, inside brave://rewards-internals, all my wallet info looks normal. Definately created and active.

1 Like

Same problem: my Brave browser disconnected from my Gemini account and won’t reconnect back.
What is happening here is that Brave counted the browser among the 4 (I think) max devices you can connect to a Gemini account, and once the browser is disconnected it will count as a different one when you try to reconnect it. So in a few months all devices you own cannot be bound to your Gemini account anymore.

1 Like

Same problem here. I can disconnect from Gemini, I can log out and sign in during the connect flow… no matter how I perform these steps I get the consistent message " Your request is still being processed, please wait. Sorry there was a problem processing your request, please try again" and I click Try Again and go through an infinite loop until I decide to bail. And it’s been like this for weeks for me.

Brave says it’s up to date for me: " Version 1.34.80 Chromium: 97.0.4692.71 (Official Build) (x86_64)"

1 Like

I even went so far as to revoke access from Brave in my Gemini account, and then go through the “Verify wallet” flow again. Same thing as before, I come back to the infinite loop.

However, it does reconnect to the wallet so this error is absolutely on the Brave side of things.

1 Like

Hi All,

Check out this thread:

It seems the ability to verify Gemini wallets might be unavailable for up to a week.

3 Likes