Brave account can't connect to Gemini Wallet for verification

Im trying to verify my Gemini wallet but it keeps telling me this message…

Sorry there was a problem processing your request, please try again.

Any ideas how to fix this? Thanks.

3 Likes

Mine still like that. According to this post https://www.reddit.com/r/BATProject/comments/s6fiy6/verifying_brave_rewards_with_gemini_is/ it should be good but mine is not

Same thing over here. I just noticed a couple of days ago my balance was zero and my wallet was “Not logged in” but at the same time there was a “Log out” link. Tried fixing it by clicking the logout link and reconnecting with Gemini. But all I get is that message in the screenshot.

1 Like

Still getting the error. No word on whether this is on Brave’s end or Gemini’s end. I’m assuming something’s changed on Gemini and Brave is not able to connect to it anymore because of that.

1 Like

Im having same issue

1 Like

Almost a month later, still having the same issue. Can’t connect Brave browser to my Gemini account. I already removed the Brave browser application linked to my Gemini account and tried reconnecting. No luck. I guess nobody at Brave cares about this?

2 Likes

Same Issue here. I’ve tried everything I can think of, went through all the help forums I can find and nothing. Would be nice to get some help.

1 Like

I’m still experiencing this also.

1 Like

Also having this issue after over a month with no rewards

1 Like

A new Brave version, 1.37.109, was just released and an “Account Flagged” error message has been implemented in the new version. You should install the new version if you haven’t already and see if the message has changed for you. Also, it looks like Brave has implemented a new process for unflagging accounts and flagged accounts will be reviewed and unflagged periodically.

Help Center article:

After the update, those who receive the new message might want to edit and update your posts indicating you received the new message. That will help separate issues with flagged accounts from other issues (hopefully).

I’m still getting Ads rewards but not the verification part. Been using Brave since Uphold, unfortunately, have to reformat my PC and my 4 device limit does not let me verify with Uphold. Now I can’t verify using Gemini… which is sad.

image

image

Same issue with Uphold. Even if I have no restriction in Uphold. It seems brave is breaking down for now.

1 Like

This happened to me as well. And I am using Uphold. SOmething is wrong with brave.

1 Like

Sad to see that my rewards are now on Limbo. No way to get this or transfer it to another wallet.

1 Like

try clearing cookies/cache, updating to the latest version as choc says, and reloading the browser. that fixed the infinite sign-in loop for me, and told me my profile was flagged and i couldnt receive ads or rewards. this looks different because some are still getting rewards but it’s worth a try :slight_smile:

I updated my browser. Cleared my cache and cookies. It logged me out of everything which was a total hassle. It still did not work. I am still getting the same dialog “Sorry there was a problem processing your request, please try again.”

One other thing: Brave already has a built-in wallet. Why not just transfer the funds there? Why rely on third-party websites like Uphold and Gemini?

I don’t know man they should let us freely use or store our BAT because we worked for it. Brave also doesn’t allow connected device management to avoid exceeding 4 devices per custodian wallet which sucks because they already earn their cut while our BAT is stuck waiting for another reformat to happen. If I’m flagged it should be on my status or just someone informs me via email/reply.

@steeven Fixed it for me. Awesome and thanks to all brave team!

1 Like

How did they fix it?

I’ve just updated to V1.37.116 and the problem still persists. Still can’t connect to Gemini. Still getting the same useless error message. Tried clearing my cache and cookies which is one big hassle considering I have so many things that I have to reauthenticate with. This is so frustrating!