Unable to install Brave Browser for the first time - unspecified error

Hi all - For the last few months on and off I have been trying to install the Brave Browser after trying it out on iOS for a period first. Whenever I attempt to install the browser, I encounter an “unspecified error” in the installation process (see screen capture below) and I have not been able to find a workaround.

I am currently running Win10 64bit (I have also tried installing 32bit just in case I was mistaken).

Steps I have taken to try and remedy:

  • Closed and ended process of Chrome Browser (I have never installed Brave so that could not have already been running)
  • Uninstalled Chrome Browser just in case of interference and restarted PC.
  • Cleared all AppData for Chrome Browser and restarted PC.
  • Tried installing across many months in the hope an update would be released and the issue would be remedied
  • Downloaded the standalone installer to make sure the issue wasn’t a download issue.

Brave Error

Any assistance for this issue would be greatly appreciated as I have enjoyed the user experience on iOS and would love to transfer to this browser on my PC.

Hello @CBrads4

just to confirm you downloaded brave from right?

and could you disable your antivirus and after download right click on the downloaded file then run as administrator

hope that help and have a nice day :slight_smile:


Could you try a different build? like beta or nighty? does those work?


Hi @justsomeone1, yes I downloaded it from the official website. I did try disabling my AV and running as administrator. Unfortunately neither of those things worked either. I just forgot to add them into the original post.

Thanks for the tip @Manti2k, I just tried downloading both the Beta and Nightly builds and both presented the same error (exactly the same as the screenshot).

1 Like

could you tell me which windows build you use is it 2004 or something else

1 Like

could you create new user account with admin permission and try it using that new account

1 Like

@justsomeone1 - just tried creating a new user account and experienced the same issue. Currently my PC is on build 1909. 2004 has not been made available to me yet.

1 Like

not sure about that but try to close as much as you can of any opening app and the one that run in the background also

and not sure if starting your device in the safe mode and install it there would work or not

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.