Unable to connect TubeBuddy account because of redirection management in Brave

Hi there! I have troubles and thought maybe someone could help me through this… So thanks by advance, hoping we will find the solution I need ! :wink:

Description of the issue: I’m a creator on Youtube, and use TubeBuddy for some of its features helping in the channel management.

But since I came to Brave, I can’t connect my TubeBuddy (TB) account to my channel. When I try to connect TB on the Youtube Channel page, it brings me to choose a Google account, and when I accept the conditions, I’m redirected directly to my channel page, with TB still not activated, and I get a notification about a blocked redirect to https://tubebuddy.com/redirects/...(many mumbo jumbo here)

  • I tried to add exceptions for account.google.com and tubebuddy.com. It did not change anything. Maybe I wrote them in a wrong way ?
  • I tried to disable secure navigation and the shield for the two sites as well. It did not work either.

(I also tried insulting my computer after spending hours on that finding nothing on the web about it, but we may all agree on the fact that it was only a useless psychological release…)

Steps to Reproduce (add as many as necessary):
1- Have a Youtube channel, Tubebuddy working on it (with Chrome).
2- Have the TubeBuddy plugin installed on Brave.
3- Go to the Youtube channel page, and click the “Tube Buddy sign-in required” button.
4- Follow the instruction to connect with the channel’s Google account.

Actual Result (gifs and screenshots are welcome!):
Notification of blocked redirect, and it goes back to the channel page with TubeBuddy still not connected.

Expected result:
Should go back to the channel page WITH TubeBuddy connected and features activated.

Reproduces how often:
Happens everytime I try, regardless of the parameters in Brave.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10
Brave : Version 1.14.84 Chromium: 85.0.4183.121 (Build officiel) (64 bits)

Ok, so we were on a classic PEBCAK situation here…

After spending hours on this and posting this long topic, I suddenly came up with an explaination for this problem…

Here it comes :

  • When I installed Brave, I recovered all my extensions from Chrome.
  • One of it was blocking some redirections, but its parameters and exception did not come with it as I reinstalled it.
  • This extension has no use on Brave, so I deleted it.
  • Now it works.

As I said, classic PEBCAK situation. For now, I might leave this post here, for other users that might encounter the same issue…

1 Like

loool that is awesome man looooooooool