[Ubuntu] No Audio from Brave | But Working from Firefox

Description of the issue: On Ubtuntu 20.04, I am unable to get audio from Brave. However, on the same machine, I successfully get audio from Firefox. If I go to Ubuntu Settings > Sound > Output> and Test, I get Audio using both the “Left” and “Right” options.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  • Go to any website that produces audio (YouTube, ESPN) using Brave
  • Play audio through website
  • No audio is audible

This problem persists after several rounds of trouble shooting:

  • Quit and restarted Brave, then repeating above
  • Restarted computer, then repeating above
  • Changed profile, then repeating above
  • Going into incognito mode, then repeating above
  • Removing shield on website (in my own profile, new profile, and incognito mode), then repeating above
  • Removed all extensions, then repeating above
  • Confirming brave://settings/content/sound is set to Sites can play sound, then repeating above
  • Confirming brave://settings/extensions has media router set to on, then repeating above
  • Updating Brave to brave-browser/stable 1.45.131 amd64 from 1.45.127, then repeating above

Actual Result (gifs and screenshots are welcome!):
No audio is audible regardless of website.

Expected result:
Audio is expected to be heard on these websites (using the same website link in Firefox, audio is heard)

Reproduces how often:

  • Had been reproducible over several days despite restarts and troubleshooting as mentioned boave.

Operating System and Brave Version(See the About Brave page in the main menu):

Brave Version - Release Notes v1.45.131 (Nov 22nd, 2022)
Ubuntu Version - 20.04.5, 64 Bit, GNOME 3.36.8

Additional Information:

Previously the audio was working on brave. The problem started after I updated Brave several days ago (to v1.45.127 (Nov 15th, 2022)).

I have read a similar post, but the solutions there have not resolved the problem for me (Brave linux no sound in videos since last two updates over the past week).

2 Likes

Hello there @jacronand13 please accept my apologies for this inconvenience. Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Let me know if that works.

2 Likes

@Kevin_cc Thanks for your suggestion and trying to help me with this problem. I disabled hardware acceleration following your instructions.

I then went to three website (YouTube, Twitter, ESPN) and played content that should have audio. However, I still do not have audio while using Brave. Although I do have audio from those same websites when I use Firefox.

1 Like

Go into your audio settings menu and make sure that Brave has it’s audio slider set to play audio. I remember someone else had a similar issue and the default to Brave was set to mute the browser.

2 Likes

@cynical13 Are you referring to an auido setting in Brave? Otherwise, in Ubuntu I have checked this before. It is at its maximum.
Screenshot from 2022-11-24 06-20-11

1 Like

Yeah, that’s what I meant.

1 Like

@cynical13 Got it. Yes I can confirm that that is not causing the issue.

As an update, I also removed Brave from my Ubuntu machine following the steps here (namely, sudo apt remove brave-browser). I then reinstalled brave-browser.

Still I get audio with Firefox but not Brave.

I also tried with a different speaker. Again, I get audio with Firefox but not Brave.

Still no change in status on my end.

2 Likes

Hi again @jacronand13 could you please try adding those sites to the one’s allowed to play sound to see if this solves the issue?

Go to brave://settings/content/sound > Allowed to play sound >Add.

Let me know if that works.

1 Like

@Kevin_cc Thank you for the suggestion. I added YouTube and ESPN as you suggested. However, still I get no audio from Brave Browser. If I navigate to the identical URL on Firefox, I do get Audio.


2 Likes

@jacronand13 Thanks for letting me know that. Could you please try opening your main profile in private or guest mode to see if the audio from those pages work? If they do, try disabling your extensions to see if this is the cause of the issue.

You can open a Guest Window by going to Main menu --> Open Guest window:

  1. On your computer, open Brave.
  2. At the top right, click Menu → More tools → Extensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.
Regards.

1 Like

Hi @Kevin_cc . Still no audio from Brave when using guest mode. However, if I put this URL into Firefox, I do get audio there.

2 Likes

@jacronand13 Does the audio work on Chromium based browsers such as Google chrome?

Also, try installing the Beta or Nightly versions of Brave on your PC to see if those pages reproduce sounds? You can install them from here https://brave.com/download-beta/ https://brave.com/download-nightly/

Be waiting for your response.

@jacronand13

Since you initially made this post, did you update to the latest version of Brave? And are you still experience this issue with audio?