Brave linux no sound in videos since last two updates over the past week

Description of the issue: Sound in videos stopped working after one update this week. Another update came in today, did not fix the problem
How can this issue be reproduced?

  1. Any video, YouTube, Bitchute, etc
  2. Already checked Tab mute setting and audio device selection
  3. Sound works in Telegram app videos and System Settings L/R speaker test

Expected result: Expect video to play with audio

Brave Version( check About Brave):
Version 1.37.116 Chromium: 100.0.4896.127 (Official Build) (64-bit)

Additional Information: Kubuntu 20.04

I have the same version and same problem with audio.
Has anyone at Brave support replied to this problem?

Hello @AngelTeam @PJK2012

could you try to disable all extension and try in private mode and see if it work fine there or not

if it work fine then the issue either with one of the extension or you need to clear your cache

if that did not help could you crate new profile go to menu then choose create new profile and without changing any settings could you see if it work fine there or not

hope that help and have a nice day :slight_smile:

Hello justsoneone

I tried disabling extensions & clearing cache but that didn’t help.
Where to create new profile? On Linux or Brave???

I discovered that on YOUTUBE a sound icon appears next to the extensions icon that allows me to cast video and the audio works on the TV. On rumble, the video works but the audio doesn’t while using the cast function from the drop down menu.

Hello @AngelTeam


if you mean this icon
Screenshot from 2022-04-16 15-39-56
it list all the tabs that has sound media or video to allow you to pause /resume or get next or before media

could you go to brave://settings/content/sound and make sure the sound is allowed that this option is selected Sites can play sound

Edit : is your issue that the sound does not work at all or when you using the cast option ?

Screenshot from 2022-04-16 15-39-56 Yes, that is the icon.

Went to brave://settings/content/sound and it is set to Sites can play sound.

The issue is only with using the cast option from the drop down menu.

go to brave://settings/extensions make sure that Media Router is enabled

also can you confirm that cast video from other app like your video player work fine

did you test that with chrome also or not?

what is your brave version and your os version ?

SOLVED The audio is working now.
The problem was that casting needs to be from source Cast Tab.
I doesn’t work when set to cast desktop (which is what I had been using)
I had used the cast desktop to get audio to work when I was using Windows 10. Now that I use Linux, it is the opposite setting needed to get audio to work !

Thanks for your help justsomeone


@AngelTeam you welcome :slight_smile:

I have tried all the suggestions on this page and I still have no sound in videos.

did the sound work before or it the first time you use brave and it and the sound never worked earlier

did you tried to create new profile and it did not work ?

Sound worked on other stuff before but I installed Brave for it’s CASTING feature so only discovered the audio problem at that point.

I tried the new profile (added a name) and that didn’t work. Actually, I don’t know if it worked or not because I was using the wrong CASTING SOURCE.

Today I experienced a problem with casting. I had to toggle back and forth the SOURCE choices to get video and audio to work. It finally did work.

@AngelTeam i think there some miss understanding here
first thanks for the info and details about your case

but last message meant to be for @PJK2012 as his issue not solved yet

sorry for this miss understanding @AngelTeam and have a nice day :slight_smile:

Yes. I did everything you have suggested. Sound was working ever since I started using Brave around the time your advertising postcard came. It stopped when an update installed about a week ago. A second update came in a few days ago, but still no sound.


first to make it clear i am just a user same as you

i do not use kubunutu but is there setting in the os that could block certain app to use the speaker or the sound of the device

Oh, how interesting. I didn’t find anything in Audio settings, but I clicked again on the Audio (Speaker) taskbar icon and saw an Applications tab there which shows which applications are playing audio. Since I had already started a video for this testing, I saw Brave (only) on the applications list. It showed Brave’s volume at 100%, but it was grayed out. So I pulled the volume back to 95% and back up to 100% again and the video’s audio started playing. Thanks for pointing me in the right direction.


glad to you that you figured it out and you welcome :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.