Transaction details on my Online Bank site reads 'loading transaction data' never retrieves

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue:
How can this issue be reproduced?

  1. Do online banking in Canada through Royal Bank of Canada from my dell laptop running windows 10 pro
  2. Have used Brave for about a year. Starting 3-4 weeks ago the bank site can be accessed and accounts viewable but the grid of banking transactions does not return. Only says ‘loading Transaction data’. This is consistent for the various bank accounts and Visa credit card through this bank.
  3. Microsoft Edge and other browsers return results properly.
  4. Spoke with banks tech support, Brave is not a supported browser. They do not have this listed as a common problem. Suggest it is a Brave issue. Did you change Brave in last month in a way that would cause this?

Expected result:
Expect to view grid with transaction results including Date, Description, Transaction amount, resulting account balance.

Brave Version( check About Brave):
Version 1.15.75 Chromium: 86.0.4240.99 (Official Build) (64-bit)
Additional Information:

Hi, Does turning off shields help?