This site can’t be reached on Brave

This is an example of the google links I’m having the problem with.

When I click on it it generates this error.

The proper page will eventually load.
Expected result:

Operating System Windows 10 64-bit Pro, Version 20H2 ;
Brave Version 1.34.81 Chromium: 97.0.4692.99 (Official Build) (64-bit)

Bitdefender Internet security Build

This has been going on for the past month.
I am unable to duplicate the problem with Edge or Firefox.
I’ve tried shutting down all extension and using a Private window.
But the browser still generates this error.
One note: The error page has a different URL than the link.
UPdate: This seems to happen primarily on Ad links, not just Google.

Same error here. Need a fix soon.

I was able to land on that page without any issue. Can you clarify what you mean by:

When you do a Google search you get a bunch of Ad links at the top of the links google provides. Those like will typically return the error described above.

Hmm, doesn’t reproduce for me. If I search “Nest thermostat” on Google, I see the following:

Clicking on any of these links redirects me to the site as intended. Can you tell me if you get the same results if you right-click on the ad, then select Copy link address from the contest menu, then paste the link in a new tab?

@gridflash I spent some time looking up this issue online and I see it’s been an intermittent problem since 2019.


  • VPN tends to cause issues. Are you using a VPN?
  • It had also said some Ad Block extensions can cause issues. I know when I click everything, I have no issues. But not sure if you have any extra extensions like Ublock or Adblock?
  • Lastly, there was another person who said it was caused by a DNS issue. After doing a DNS flush, things worked fine.

I’m going to link to a help thread about it if you want to read the hundreds of comments, but then also going to just simply quote here the primary things people kept saying solved it for them. This is coming from’t-be-reached-www-googleadservices-com-refused-to-connect-err-connection-refused?hl=en

I dont know if you’ve solved the problem, but I came here just as frustrated as you, and couldn’t find help. But I just tried something that I think might work. If you have the “Adblock” extension (red sign with a white hand like on the attached picture), try opening that. On the left column open “customize”. Under “stop blocking ads” you can open “show ads on a webpage or domain” and enter both and After I did that I could enter the webpage again. I might be worth giving it a go?

This happens to me ever since I installed Norton VPN. When I turn the VPN “off”, the problem goes away.

I just tried the exact same scenario using Chrome and the Bing search engine. The same AD links work correctly!

If Google will not allow my searches and clicks to work, then I will switch search engines!strong text

Then, Microsoft had one. This was what was marked as the solution:

It sounds like your DNS settings may be wrong, so I’ll show you how to reset them:

  • Click Start, and type “cmd”.
  • Right-click Command Prompt and run it as administrator.
  • Copy and paste the below one line at a time, pressing enter each time:

netsh winsock reset - and press Enter.
netsh int ip reset - and press Enter.
ipconfig /release - and press Enter.
ipconfig /renew - and press Enter.
ipconfig /flushdns - and press Enter

Once you’ve done this, reboot, then see if the same problem occurs.

Try those if you would and let us know if you see any difference.

@Mattches We’ll see if the above fixes the issues, but I wanted to tag and share this next one with you because if it doesn’t, I’m wondering if the two might somehow be related. If it is, I’m not sure what the Brave equivalent would be. If you have time, mind looking at the link below?

I’m interested to see if the above resolves the issue as well. The thread you linked is similar but it appears that @gridflash is actually only getting this issue with “ad” links but can view most websites as intended. @gridflash can you confirm that that is the case?

That is the case.

And thanks to [Saoiray] for that post.

That’s the page I get eventually, after about 10 secs.

ah good to know, it wasn’t just me

This seems to be a Google Ad services problem.
If I use Bing to do the search I don’t have the problem with the links.

I’m also inclined to think it may be on Google’s end. I will dig into this issue a bit more though and try to confirm.

I too get the same error when clicking on the Google Ad links you get after a search.

Has a solution been found yet?


I think this is Google’s attempt to make Brave’s Adblockers useless…

@Mattches, did you ever figure out anything on this? Asking as we have 2 other posts now. So I guess it’s still an issue for people.

If you temporarily disable shields (globally) via brave://settings/shields does this help? @gridflash

Disabling one of the major features of this browser seems to work.
I assume this was Google’s intention all along.
It only works when the shields are disabled.
If I set them to 'Standard" the error screen comes back.

Can you copy and paste the full url being blocked?

Looks to be similar to