NEST quit working

Description of the issue:
I just installed the latest version of Brave. All seems to be working fine except I can no longer login to my NEST (home.nest.com) account. From the Nest site I get an error page including “An unexpected error has occurred.” I can still login without any problem if I use Google Chrome.
Steps to Reproduce (add as many as necessary): 1. 2. 3.
www.nest.com
Select Sign In > My Nest home
Get error page
Actual Result (gifs and screenshots are welcome!):


Expected result:
Supposed to ask for password
Reproduces how often:
Every time when using Brave
Operating System and Brave Version(See the About Brave page in the main menu):
Windows10, Brave Version 0.68.139 Chromium: 77.0.3865.90 (Official Build) (64-bit)
Additional Information:

1 Like

@LAdams17,
Thank you for reaching out to us. Can you try clearing your cache/site data for nest?

  1. Visit home.nest.com
  2. Click the “lock” icon in the address bar
  3. Select Site Settings, then click Clear data
  4. Make sure you refresh the page afterwards

Now attempt to login again – let me know what you find out.

I have the same problem. I tried to follow the instructions, but the “lock” icon only gave me the option to forget or manage my passwords. There was no “site settings” link or option. For what it is worth, I tried selecting the option to forget my password. It did not help. Any other thoughts?
Also, for what it is worth, I am not having this problem on Chrome, Firefox or the beta version of Edge.

@tomstubbs,
You can find the Site settings option here:

@tomstubbs @LAdams17,
Scratch that – I see the issue. I’m not entirely sure why, but it seems that you need to change the cookies setting in Shields to Allow all cookies. Doing so reloads the page and the login fields/Google login option will appear.

cc @fanboynz for why cookies need to be allowed? I believe this should work with default Shields settings.

I see accounts.google.com cookie is being requested, and then being blocked. Hmm

Just investigating whats going on, just prodding a few people to take a look

1 Like

Thank you. Setting Shields to Allow all cookies worked.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.