Ad search result links to Home Depot ads no longer work, site cannot be reached error then black screen

Problem description: Brave presents ads as a row of images at top of a page of results as usual. Clicking on any Home Depot ad image brings up an error page that says “site cannot be reached” followed by a whole bunch of characters filling the page, then a black screen appears. Note: links to other sites e.g. Amazon, work.

How to reproduce problem:

  1. Search for an item e.g. “Great Stuff Pro”
  2. Click on any Home Depot Ad
  3. Wait a few seconds

Expected result: page corresponding to the ad opens on Home Depot Site.

Brave Version: 1.37.116 Chromium: 100.0.4896.127 (Official Build) (64-bit)
](https://brave.com/latest/)

Additional Information: Problem suddenly appeared a week or so ago. Problem does not occur with Chrome alone. i.e. links open the relevant Home Depot page.

|Device name|LAPTOP-K2P80VOJ|
Think Pad P52S
|Processor|Intel(R) Core™ i7-8550U CPU @ 1.80GHz 1.99 GHz|
|Installed RAM|16.0 GB (15.8 GB usable)|
|Device ID|9825985F-29C4-4B8C-9A57-D60E6A9C9725|
|System type|64-bit operating system, x64-based processor|

Windows 11 Home|
|Version|21H2|
|Installed on|‎2/‎1/‎2022|
|OS build|22000.613|
|Serial number|R90QM50Q|
|Experience|Windows Feature Experience Pack 1000.22000.613.0|

Hi and welcome to the community. :smiley:

Have you tried disabling shields? You can disable shields for just that site and it will be put in the “allowed” list for cookies and other site data at brave://settings/cookies. Once you are finished, you can enable shields again and the site will be removed from the “allowed” list.

Yes, I disabled shields and behavior remains as described. Interestingly when I click on ad results from other sites e.g. Walmart, I temporarily get a similar “site cannot be reached” error that then resolves and the site page opens, but not for Home Depot. I have an account with Home Depot so wonder if somehow this could make a difference. As mentioned in my post, this behavior manifested a week or so ago though I do not recall any changes I made to Brave or my Home Depot account.

Have you tried logging into Home Depot in one tab then clicking the ad in another? Just wondering if this makes any difference.

Sorry I don’t have any other suggestions besides the above and clearing history/cache, exiting brave, and reopening. Maybe something got glitched.

Thanks for the suggestions. I tried them all and problem persists. If I see a Home Depot ad I like, I will just go to their site and redo the search and try the ad links occasionally. If OK, let’s leave this open until autoclose.

1 Like

Maybe another community member will pop in with suggestions. Hope so!

I don’t know what country you are from, but it is a holiday weekend here in the USA and Brave support staff may not be back until Tuesday. If you are still having problems then, you can tag the moderators (Steeven and Mattches) and hopefully they may have additional suggestions.

I need more details, where are these searches done? are they done on home depot?

Same problem occurs with Lowes.

# Access Denied

You don't have permission to access "http://www.lowes.com/pd/Hisense-Hisense-21-6-cu-Ft-Counter-Depth-T-Type-French-Door-Refrigerator/5002071597" on this server.

Reference #18.a6a96068.1650275665.fb3c3b57

That error @PicklesTheDrummer ?

I do a regular search and a scrollable series of ad images appears at the top of the search page


When I click on a Home Depot ad I get this error immediately followed by a black screen. The error disappears so quickly it is hard to capture or I would have included it earlier in the post. A similar error will appear at times (not always) with other sites though instead of a black screen, the target page opens within a second or two.

relatedly this image shows the address bar above the black screen that appears right after the Google error screen above, again, just for Home Depot ads for me. Interestingly if Brave/Chrome chooses to show ads to the right and not as a left/right scrollable strip across the top, and I follow the “show more on Google” arrow then I get a page full of ads and clicking on Home Depot ones work correctly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.