The Brave swag store won't let me checkout on the Brave browser!

I’m using the Brave browser with default settings. When I go to the Brave store, and my browser has shields enabled, I actually can’t checkout. I get stuck on this screen (see attached). After disabling shields, I can move onto the next step.

I think fixing this would help support the Brave project!

From the image above, I noticed Contact Information/Shipping Address is empty, Can you re-test (clear cookies) and refresh the page with these details filled in

Of course. Same result - clicking on the button does nothing even with the fields fully filled in correctly. I had to disable my shields to checkout. (That’s how I noticed the issue)

Which shield option is causing it?

Nevermind, sorry. Just tried again after clearing my cookies and it worked fine? Probably a false positive on my end. :man_facepalming:

This is the only tracker I see that is blocked:

Thanks for the heads up regarding the tracker, looking into it. Probably caused by the shopping website template used.

Great to see it now working also