Sync Code Entry doesn't do anything

I’m on a Mac, running the latest Brave on the latest MacOS.

I’m trying to get my copy of Brave to join a sync chain. But typing in the sync code and pressing confirm sync code doesn’t do anything. In fact if I type random words into that box nothing happens. Is something broken in the service or am I misunderstand? Thanks!

@Pitosalas,
Thanks for reaching out. We recently made some changes to the way Sync functions that may have a part in this. If you return to brave://sync after doing this, do you still get the same Sync Setup screen (as if it were your first time trying to add the devcie to the chain)?

Thanks for responding. I am not sure exactly what you mean. But, if I launch Brave now and go to that url I see the screen you show. And then if I click on “I have.,…” I get the screen with confirm sync code. If I type random text in the box and click confirm, it just sits there, see below. And in case its significant, there’s an odd outline around the button.

Pito Salas

Brandeis Computer Science

Volen 134

@Pitosalas,
Can you try re-entering your Sync code again and double-checking to confirm that you’ve not just entered the right words, but also the appropriate number of words?

What is the right number of words? And, still if it’s the wrong number it shouldn’t just hang should it? I have the words written in a text file (to get from one computer to another) so there might be a typo. But the count for my string is 24 words.

Pito Salas

Brandeis Computer Science

Volen 134

1 Like

I have some more info… I verified that I had the correct words from another instance of Brave. When I pasted those into my MacOS Brave it hung like described before. But when I pasted the same words into my iOS Brave it worked well. Another factoid. When I first tried this recently I got an error saying that the sync string was wrong. I dont remember whether it was in fact wrong but I did get that error. From that point on the error is not appearing and the form hangs as described previously. Is there maybe some state somewhere that’s stuck?

This sounds like something I went through a little while ago… Computers were synced once before, but not doing so lately… The gist I took to reenable sync to not sit there dumbly, was:

#1. reboot the computer
#2. On the source computer, where I get the sync code to copy, check the sync code hasn’t changed. In my case it did, so recopy the sync code.
#3. On the computer I want to sync, put in new sync code.

Sync’ing then “worked”… I put it in quotes because while syncing took place, it treated everything as never been synced and ended up with double bookmark entries in both computers…

So… my suggestion to you before getting sync to work is to first get a copy of your source computer’s bookmarks manually by going into bookmark manager and exporting bookmarks via Hamburger (3 vertical dots) menu > Export as an html file. Then you can go about resetting sync if you want, but honestly with a hard copy of your book marks, which can the be imported through bookmark manager, I wouldn’t bother with sync.

Edit: Note I’m not sure rebooting the computer was actually necessary…

More info: I uninstalled and reinstalled Brave on my Mac and that didn’t change anything. Entering the correct sync code into it leaves it hanging not doing anything.

More info: I installed brave beta and the syncing works fine.

Hi everyone!

I thought I’d post my question here instead of starting another thread.
I was wondering if Brave has an offline sync mode like Firefox does? The reason I’m asking is because I an setting up a fresh Windows install on my PC using a separate SSD which means I cant’t have two versions of Brave running in order to do the sync. Is there a way around this?

(I guess I could sync to the laptop and then resync to the new SSD? Or is there a better way to do it?).

Many thanks