Sync ain't working again

I have brave on my macbook air, and on my old iPhone 6S.

Latest versions. Bookmarks used to be synced, not anymore.

On the iPhone, I see ‘Enter the sync code’…I can either Copy or click Done.

On https://support.brave.com/hc/en-us/articles/360021218111-How-do-I-set-up-Sync-, and on my MBA, it gives me a QR code.

I see no option to scan this, even though they both say

image

They used to be synced. I cleared the cache, maybe it unsynced.

Why is there no option to scan the MBA code from my iPhone?

@apachewolf Often when you go to add a device, it will default to asking you to put in the sync code manually. When you see that, usually on the bottom or bottom right, there’s a little link that says Scan QR Code. This will allow you to do that instead. Otherwise you just get the sync code phrase and enter it manually.

Should still be synced. Clearing cache doesn’t erase that. If you go to Settings → Sync does it show like it’s on a sync chain or you telling me it’s disconnected? It may not have the scan option or anything if it’s already added…as there’d be nothing to do.

So like I mentioned earlier, check your settings → sync. Not only to see if they show that they see each other, but also then to go and look at what you have checked off to share. If you haven’t checked/toggled bookmarks or it somehow become unchecked/untoggled, then that might be it.

Do let us know if any of that solves it. I just wanted to start at the simpler side of things and kind of go from there.

@Saoiray thanks for your reply. There’s no “Scan QR Code” anywhere on the phone. Looks like this:

If I go to Settings → Sync, on my iPhone, it shows no other devices.
If I go to Settings → Sync, on my MBA, it shows 2 other devices, but I’m not sure what they are. Old phones maybe.

It’s because you chose Add a computer in what you’re showing. I actually just typed out the steps and showed screenshots for someone else, let me link you to that really quick instead of me repeating it all again.

@Saoiray @apachewolf It only allows you to scan a QR when you first sync it to something. Once you are synced to another device, you can’t use the camera again. I did what Saoiray told me to do on my thread, and I was able to un-sync and resync to my laptop by doing what he suggested.
I am still trying to figure out how to sync my work computer other than having to type everything.
I wish there was an easier way to do it. Like maybe allowing us to use the phone camera on multiple devices to sync them all.

1 Like

That’s correct, because that no longer is being added to anything, so it wouldn’t scan with a camera. You’d be doing like you did on the desktop with your third device. If both devices are showing like they are on a chain, then you either have them connected already or you accidentally started a chain on both and need to leave the chain and follow the instructions as I mentioned prior.

Oh, and just noticed you responded on Apache’s topic. Let’s try to keep yours over on your topic. I just had linked my response from yours to him so I didn’t have to repeat it all and upload stuff again.

Well, that’s what I’m trying to do. I’m trying to sync my iPhone with my laptop.

As a comparison, I’ve removed and reinstalled whatsapp and similar apps. They work similar. Each app allows me to scan a QR code on the desktop/laptop version, and it regains usage.

That doesn’t seem to be happening here, with the brave iOS app.

@vamanos I’m glad you mentioned that. I think that’s what’s going on. Perhaps I synced these two already, but, they are not actually syncing now.

I renamed my iPhone. I don’t recall what it was before. Maybe that’s the issue.

One my phone, it shows no other synced devices.

On my laptop, it shows 2 synced devices, named like AMK-L25 and PGLM650. Since they’re cryptic, I don’t know if either is or was my iPhone.

Maybe renaming devices breaks the sync?

Would be great if I can just use the camera again to sync or the device names showed if either is my MB.

Update: I removed the 2 crypticly-named devices from my macbook and tried to resync, and the messages don’t match up.

macbook says to scan:

Screen Shot 2022-08-28 at 1.31.31 PM

phone still says to enter code, and offers no camera option:

image

Either I’m doing something wrong, or, brave is telling me one thing on desktop, another on the iPhone.

I’m starting to wonder if it’s just an older iPhone that’s causing an issue. How about you try this…on the Macbook one, do you see where it says to scan the QR code? Right next to the OK button is one that says View Sync Code. Just tap that and it will give you the code. Then you’ll be able to put that in on the one your iPhone is populating. This should let you connect.

Come to think of it, you never did say what version of Brave you’re using. I’m wondering if yours is outdated at all. If so, that can cause a problem. I know you said latest versions but I’ve had people say that only to find out they weren’t, they just thought it would auto update or whatever. So not to doubt you, but can you just confirm and say which specific version each is running? After confirming, might see if we can tag Michal or Mattches over to see if they have any ideas. But I kind of want to cross that out first.

I may not have been clear. The goal for the post was to see if I could use the camera, and not have to type in the code.

iPhone: 6S. First line of post.

macbook:
Brave is up to date:
Version 1.42.97 Chromium: 104.0.5112.102 (Official Build) (x86_64)

Yeah, I saw that. I was saying that’s an older iPhone and I just am wondering if that might be part of the problem. Well, I was anyway. Just editing after I researched. I had seen sites that said iPhone 6 didn’t get new updated after 12.6 or something like that, but now I’m seeing Apple’s Support where it says iPhone 6 did get 15.5 and all.

If you hadn’t heard though, iPhone 6 is losing support soon. In any case, I’m kind of starting to go off topic with that…

So you shared version of Brave for Macbook but what about iPhone?

In the meanwhile, I want to tag and see if @michal has any ideas why it might not be opening the camera to let you scan QR.

ok, I see how that might be an issue.

iPhone version is 1.42 (22.8.15.22).

ok, typing extra for the 20 character minimum.

any news on this?

Damn it, I have to revisit here. @apachewolf I think we might have missed something simple. I just removed tags for Support because I don’t think they are needed. Let me clarify something with you here.

Both pictures you showed before actually showed they are part of a sync chain. Maybe they aren’t on the same sync chain, but they are part of a chain.

So here’s what we’re going to do. You’re going to need to remove devices from the sync chain. Probably better on iPhone since you said nothing seems to be showing up there. So on iPhone, go to SettingsSyncGear icon on top rightDisable Sync (Clear Data).

Then completely exit. When you go to SettingsSync again you should see options to either Start Sync Chain (which you don’t want to touch) or I have a Sync code (or something like that). Tap on I have a Sync code and you should have the option to scan a QR code.

What happened in the screenshot in the August 28 one is you were showing that both devices were offering the sync code for another device to be added.

I’m so incredibly sorry that I missed this. We kind of danced around it but I should have noticed. I got distracted and saw “empty gray blocks” back then and thought that’s what you were seeing. Common sense didn’t hit me to realize that was you censoring out the codes! Hopefully you can do as I just mentioned and all should be fine for you. Again, sorry :bowing_man: :bowing_man:

1 Like

That’s ok. Yes, it said the code was like a pw, so I blocked it out.

Thanks @Saoiray for getting back to this. I think we’re making some progress. I did “Disable Sync (Clear Data)”, exited, reopened, went back to Settings → Sync, and it now shows:

Went back to Sync, “Add New Device”, Computer, “Enter the Sync Code” like above.
macbook offers a QR code again, however iPhone still not offering to scan the code.

Now what, Clear Data from macbook?

@apachewolf Not sure how long you waited, but I just left my Sync chain by doing as I told you with my iPhone. Originally I was seeing the same thing as you. Admittedly, I took a few extra steps when I did and not sure if any of the particular made the difference or if it just was time. I’ll explain what I did, then up to you if you want to follow in my footsteps to see if it makes an impact OR if it’s just a matter of time for it to show the proper page under Sync)

So starting from when I first hit Disable Sync (Clear Data):

  • I closed everything and swiped away Brave. Then saw the same as you in the screenshot.

  • Said What the F and then hit the gear icon on the top right, noticed no new options. Decided to hit Stop Sync (Keep Data) to see if it made an impact. Went backwards, exited, tested again with no change.

  • Went back to Sync and clicked Request Start and went back. It ended up creating a Sync chain with my iPhone only listed.

  • I tapped my iPhone on the list and then chose to remove it from the sync

After all of that, it showed me the proper menu:

Usually just doing the Disable Sync (Clear Data) brings you to the menu I’m showing in the screenshot above, but I guess something screwy went on with iOS this time around.

So of course, if adding the iPhone to an existing chain, you’ll hit the little words I have a Sync Code that appears under the larged orange one that says Start a new Sync Chain. Make sure if you have fat fingers or anything like many of us do, you’re careful to only hit the smaller one underneath.