Switching off Google Suggestions does not work

I use the Google search engine as it simply works, where as the brave browser is rather poor.

But Google throws up an enormous amount of suggestions while I am typing, and it sort of autoselects the suggestion on the basis of which line my mouse cursor is in alignment with.

The method to kill the autocomplete off is this:

**Navigate to Settings → Advanced → Privacy and Security —> Autocomplete searches and URLs —> OFF

And it does not work.

How to Disable Search Suggestions in Brave for Desktop

To disable search suggestions in Brave for desktop, follow these steps:

  1. Click on the three horizontal lines in the top-right corner and go to Settings .
  2. In the left-sidebar, select Security and Privacy .
  3. Turn off the Autocomplete searches and URLs toggle.

Turn Off Google Instant Suggestions In Google Chrome

Turning off autocomplete in Chrome is a fairly easy matter. To turn off Google’s suggestions in Chrome, follow these steps:

  1. Open Chrome.
  2. Click on the hamburger menu (≡).
  3. Click on Settings .
  4. Under People , click on Sync and Google services .

I mean there are some good things about the google software but control and “off” isn’t one of them.

The google search engine is way better than any of them, but it just comes with functions that are kind of insane and hard to turn off.

Any help with this would be appreciated.

Hello @Kuntsium

this about the address bar so it turn of the autocomplete when you type in the address bar

but if you type in google.com page that would not affect it

hope that help and have a nice day :slight_smile:

Hi

@Kuntsium To disable google search suggestions in URL bar, open brave://settings/appearance and check as in below image.

2 Likes

Yeah did all the appearance thing… but it’s a GOOGLE issue, in the browser, and not a Brave Search Engine - issue.

Hence the abstract complication to do a simple thing.

Turn Off Google Instant Suggestions In Brave Browser
Since Brave is based on Chromium, turning the search predictions off is actually similar to Google Chrome.

To turn off Google’s suggestions in Brave browser, follow these steps:
This does not work either.

https://silicophilic.com/turn-off-google-instant-suggestions/

Open Brave.
Click on the hamburger menu (≡).
Click on Settings.
Scroll down and click on Additional settings.
Under Privacy and Security, turn the toggle towards off next to Use a prediction service to help complete searches and URLs typed in the address bar.

This does not work either.

https://silicophilic.com/turn-off-google-instant-suggestions/

Turn Off Google Instant Suggestions In Brave Browser

Since Brave is based on Chromium, turning the search predictions off is actually similar to Google Chrome.

To turn off Google’s suggestions in Brave browser, follow these steps:

  1. Open Brave.
  2. Click on the hamburger menu (≡).
  3. Click on Settings .
  4. Scroll down and click on Additional settings .
  5. Under Privacy and Security , turn the toggle towards off next to Use a prediction service to help complete searches and URLs typed in the address bar.

This does not work either.

Click on the hamburger menu (≡).
Click on Settings.
Scroll down and click on Additional settings.
Under Privacy and Security, turn the toggle towards off next to Use a prediction service to help complete searches and URLs typed in the address bar.

is the autocomlete you talking about is on google.com page or what

if yes then there no option for that

Yeah I am using the google search engine in the brave browser.
I tend to despise google, but their search engine is very good, where as the brave browser gives very limited amounts of returns and if I am looking in Australia for a specific issue, then it has a tendency to return results from all around the world… and very few in Australia.

And yes, I am setting the search locality to Australia…

But google throws up HUGE lists of suggestions and there is no way to kill them off apparently.

i need answer to that

cause this

could mean you search using the address bar area or you go to the webpage google.com and search their

naa it’s the google search engine in the brave browser.

then as @CerealLover said

go to brave://settings/appearance and turn of Show autocomplete in address bar

also go to brave://settings/privacy and turn off Autocomplete searches and URLs

if that did not help then could you record a video or send screen shot about what you trying to achieve