Start up Without PreLoading all Pages


#1

Is there any option with which i can start up Brave and load only tabs that i went to.
Its a little bit strange couse some tabs “load” (working in task manager view already after startup)
and some not, load after clicking it (and only after that visible in task manager).
Ex.
I have 10 tabs on startup im in tab 1 and i dont want tabs from 2 to 10 to load (even in task manager /background/) until i click them.
Now.
I have 10 tabs on startup im in tab 1 (visible in tm) and have 4 tabs more unload (but working in tm view) and 5 tabs unload (not visible in tm view).

I just want as many memory and cpu free for other apps.

If there is option like this. #support-and-troubleshooting

If there isnt option like this. #brave-feature-requests


#2

@Cheshire, thanks for reaching out.
I think there’s a flag or two that may help with this.

  1. In the address bar, type Brave://flags
  2. Search for a flag called #expensive-background-timer-throttling
  3. Enable this flag and relaunch your browser

Let me know if this resolves your issue.


#3

I dont think thats it still preloading tabs probably lowering their CPU usage a bit but its not what i was looking for (disabling all preloading).
Im looking for it bec i often have 20-30 tabs in use and if brave preload even half of them it will be taking without the need a lot of memory (1 idle twitch tab after preload taking even 150+k).


#4

@Mattches, previous Brave (muon) is do lazy load tabs on start up, IIRC. It’ll only load the active/focused tab.

Should we log a request for this? :slightly_smiling_face:


#5

Let me ask around a bit, I feel like I was just talking to someone about this.


#6

Yea i figured out that it load only last used tabs but tab become active/focused after 1-2 visits also i couldn’t find any flag with anything common to preloading it will be nice if there was a flag that i can just disable and get rid off this.