Spotify playback issue widevine is turned on but spotify isn't working

issue reproduce

1.https://open.spotify.com
2. You get a screen that says " Enable secure playback in your browser"
3. The instructions to enable Spotify web player say that for Chrome you have to “Allow site to play protected content”
4.It was already allowed in my settings, but it doesn’t work.
5.widevine is turned on.

Expected result:

Brave Version( check About Brave):

Additional Information:

hI

@alpha34 Open brave://settings/content/protectedContent , and enable as in image

The setting is already enabled as seen in the image

What device you have?
Try to run Spotify in a new private window: Open Brave, then hold CTRL+SHIFT+N
Try google dns 8.8.8.8, 8.8.4.4
Check firewall

I have a similar, but different, issue. Video doesn’t play on a school website. The videos are not hosted on YouTube or Vimeo, but have their own watermark.

Example at https://www.soilfoodweb.com/resources/animations-videos/?vID=372925873%3Fh%3D707aa77aa3

The videos play fine in Safari.

I use a desktop Mac mini, Apple M1 chip, macOS Monterey 12.3.1.

I logged into the website and navigated to a video and pushed play.
It didn’t play.
Took the shield down.
Confirmed that Widevine is on.
Confirmed that “sites can play protected content” is enabled.
Restarted browser for good measure.
Still doesn’t play.
With the advice here, I tried it in a private window (shields still down).
Still doesn’t play
I don’t understand the Google DNS thing.
No firewall to check.

Any more suggestions? Thanks.