Spotify web player is not working any more

Description of the issue
Since a few days it is not possible to listen to music on Spotify anymore. This seems due to a change in Spotify, not in Brave. The page loads normally, but if you try to listen to a song, the following message pops up:

An error occurred

Spotify no longer supports this version of Chrome. Please update your browser for uninterrupted listening.

Might have something to do with Widevine. There are failed (HTTP 400) requests that hint to it:

These errors are not there in Chrome - and playing music still works there too.

I’m using a Spotify premium account (in case it makes a difference on how they protect their content).

There are other people with the same recent error. No solution yet. Might be related:
https://twitter.com/search?f=tweets&vertical=default&q=spotify%20error%20chrome&src=typd

Exact URL of the website in question

Did the issue present with default Shields settings? [Default states are: Block: Ads/Trackers, 3rd Party Cookies, 3rd Party Fingerprinting Allow: Encrypt Connections enabled (HTTPS), Scripts] (yes/no)
Yes

Does the site function as expected when Shields are turned off? (yes/no)
No

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no)
No. It’s broken in all possible settings.

Does the site function as expected when using Chrome? (yes/no)
Yes

What Operating System and Brave version/Build are you using when you encounter the issue?(See the About Brave page in the main menu)
Version 0.67.125 Chromium: 76.0.3809.100 (Official Build) (64-bit)

Got same problem. Yesterday everything was working well.

Arch Linux 64x, Brave Version 0.66.101 Chromium: 75.0.3770.142 (Official Build)

@sTiKyt,
Please ensure you’re using the most up to date version – should be v.0.67.125 at the time of writing this.
@Fleendab,
Have you installed/run the widevine plugin previously? I assume you would have had to if Spotify is just now starting to behave this way. Can you tell me what operating system you’re using as well?

Have you installed/run the widevine plugin previously? I assume you would have had to if Spotify is just now starting to behave this way. Can you tell me what operating system you’re using as well?

Yes, the widevine plugin is installed. I even reinstalled it (removed .config/BraveSoftware/Brave-Browser/WidevineCdm), but it did not make a difference.

I’m using Ubuntu 18.04.3 LTS.

Interesting side note: If I close everything and freshly log into Spotify, sometimes I manage to play a single song for a few seconds. After that, the error message comes persistently.

I have the same issue.

Brave 0.67.125, Chromium 76.0.3809.100, Archlinux

@Fleendab,
Thank you for bringing this to our attention and for leaving such a detailed report. Just spun up a fresh Ubuntu VM to test and can confirm that I get the same results. It looks like, even though the Widevine prompt did appear, it didn’t actually install – or so I thought.

After testing Spotify, I checked Netflix to see if I could stream content there (which also requires Widevine) and it worked without issue. So as you initially stated, the problem does seem to be something that changed on Spotify’s end.

I’ve reached out to a few team mates who might be able to help – I’ll return when I have more info. Thank you for your patience.

1 Like

I did re-test in windows (I don’t have a linux install), but it seems to work well. Included some new trackers also.

Hi ,

Any updates on this issue ? :frowning:

Workaround

Copy the widevine library from Google’s Chrome and restart Brave:

$ cp /opt/google/chrome/libwidevinecdm.so ~/.config/BraveSoftware/Brave-Browser/WidevineCdm/

This upgrades “Brave`s” widevine extension from version 4.10.1196.02 to 4.10.1440.182. The versions are visible in the payload of the POST request to https://gew-spclient.spotify.com/widevine-license/v1/audio/license.

By using Google’s extension Spotify’s web player works as intended again. Successfully checked that it doesn’t break Netflix in the process.

Update:
You can obtain the working library also from Google’s servers:
https://dl.google.com/widevine-cdm/4.10.1440.18-linux-x64.zip