Spell Check Dictionary Download Failed (Linux)

I see posts on this topic but only on Windows systems so I am creating a new thread for Linux.

Description of the issue:

The spell check dictionary for English (United States) will not download in Brave for Linux (on Chrome OS). I am using a fresh Brave installation on a new device. The spell check dictionary did not dissappear, it just did not download in the first place. Under the “Use spell check for” in the “Languages” section, the error reads “spell check dictionary download failed.” and gives the option to click “Retry.” When I click “Retry”, I get the following error: “Please check with your network administrator to make sure that the firewall is not blocking downloads from Brave servers.” I am using a home network and am able to run Brave with the English (United States) spell check dictionary installed on a separate Mac and separate Linux machine without issues.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Follow steps to install brave for Linux: https://brave-browser.readthedocs.io/en/latest/installing-brave.html#linux
  2. Run “sudo apt update” and “sudo apt upgrade” following install.
  3. Check to see if the English (United States) spell check dictionary has downloaded. It still has not for me.

Actual Result (gifs and screenshots are welcome!):

Operating System and Brave Version(See the About Brave page in the main menu):

2 Likes

Hi @Turn,
Are you using a VPN or any anti-virus software?

Hi Aa-ron (great name), no I am not.

1 Like

I’m experiencing the same problem.
Have tried different dictionaries.

I’ve recently also had some other issues on my system that led to me having to delete the Login Data of Brave since this was somehow corrupted.
So maybe this is related to this in some way.

Where would these dictionaries be stored?
Maybe deleting what has been stored until now would allow for installing dictionaries again.

1 Like
~/.config/BraveSoftware/Brave-Browser-Beta/Dictionaries/

but is not work
i download dictioanaries from chromium en-US-3-0.bdic but not work

is not nice link for download dictionaries or brave no connect with system network :slightly_smiling_face:

I am having the same problem, and I have a workaround to offer, at least for Linux systems. The directory where Brave stores its dictionaries is:

~/.config/Brave-Browser/Dictionaries

On my system, that directory is empty. However, I have both Chromium and Chrome installed, and they have equivalent directories with dictionaries:

~/.config/chromium/Dictionaries/en-US-9-0.bdic
~/.config/google-chrome/Dictionaries/en-US-9-0.bdic

I copied the file, “en-US-9-0.bdic” to the “Brave-Browser/Dictionaries” directory, then restarted Brave, and spell checking started working.

I have tried this on Linux only. Hope it helps!

1 Like

same issue here (windows 10)

Hi @dvdfrd - thank you very much this worked!

I went into the config files on another computer that I also have Brave installed on, copied the dictionary file, pasted it in the dictionaries directory of the computer which was having the issue, then restarted Brave and the computer.

Thanks again!

@dvdfrd,
Thank you for this information

I did an experiment. I uninstalled Brave, uninstalled Chrome. (I had installed Brave then installed Chrome to try to fix the dictionary issue with no success.) After uninstalling, rebooted, then downloaded and installed chrome, then downloaded and installed Brave. Spellcheck and Dictionary in Brave now work.