Shields defaulting to off

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue:
How can this issue be reproduced?

  1. Use Brave v1.39.111 for some amount of time
    2.Notice that Shields are now off when browsing to new sites

Expected result:
Expected Shields to be “on” at new sites

Brave Version( check About Brave):
v1.39.111 on MacOS

Additional Information:
This happened about a week ago, I cleared the entire history (cookies, shields db, etc) and that fixed it. Now, a week later, the problem recurs.

1 Like

“Clearing shields after browser close” was not enabled.

Would you mind trying to create a new test profile (ensure you close the original profile window you had open), browse for a bit using it, and tell me if you get the same behavior?

Sure, will do. The first occurrence took probably 6-9 months to occur, the second occurence happened within about a week of the first occurrence. I’ll create a new profile now.

Interesting — can you also tell me if it’s turned off for specific sites or for any/all new visited sites?

When the problem occurs, its for all sites, regardless of whether they were once “approved” or whether they are brand new, never visited sites.

It happened again - today. I had created a new test profile but hadn’t gotten to moving to it completely (long weekend). Is there any debugging I can do now, in its current state, before I move over to the new profile and essentially start over again? I’d hate to have to do that :frowning:

@Mattches I should have included you in the above post, sorry.

To be clear, you are seeing this behavior in the new profile or no? You can test this before moving everything over to see whether or not this will help.

@Mattches Seeing the behavior in the old profile. In the new profile, shields are defaulted to on since I’m starting with a new shields db I assume. Its a chore though to re-allow all the sites that I previously allowed via shields - perhaps there’s a better way?

Ideally I’d like to resolve the issue in your original profile. If it’s not happening in the fresh profile then it’s highly likely something to do with your specific Brave instance you’ve been using.

One thing to try (in your original profile) and test is setting your Shields back to Shields v1 and test to see if you get the same behavior. To do this:

  1. Visit brave://flags
  2. Search for Shields here
  3. Set the flag Enable Shields v1 to Enabled
  4. Relaunch the browser when prompted.

Then test to see if you get the same results when using Shields v1.

@Mattches using your trick to enable shields v1 in the old profile does not fix the problem, it remains.

Hello @N6GQ

using your old profile could you try this

  1. go to any site that you never visit before and check if the shield work fine there or not

  2. go to brave://version/ and look for Profile Path this will show you the bath to your profile so go to there there will be a file called Preferences search for this word in the file braveShields the second match would show you some site in front of it (those the site that has custom configurations ) if those are the site you have issue with then go check the file Preferences permission maybe it’s permission changed and does not allow brave to save the new settings

this file should have full permission for your user

hope that help and have a nice day :slight_smile:

@N6GQ

What has worked . . .

In a Brave Browser > New Window, go to: brave://settings/clearBrowserData

For tab On exit - set:

  • Disable: Site and Shields Settings

Click on the ‘Save’ button

Return to: brave://settings/clearBrowserData

For tab Advanced - set:

  • Time range:All time
  • Enable: Site and Shields Settings (DELETES Shields Settings and RESTORES default: Shields UP for site-specific Shields [Lion icon] panel)

Click on the ‘Clear data’ button.

(The ‘Clear data’ button also saves the selections.)

In a Brave Browser > New Window, go to: brave://settings/clearBrowserData

For tab Advanced - set:

  • Time range:All time
  • Disable: Site and Shields Settings (So henceforth, Site and Shields settings will not be deleted)

Click on the ‘Clear data’ button.

(The ‘Clear data’ button also saves the selections.)

Restart Brave Browser.

Recommend: In a Brave Browser > New Window, go to: brave://flags

  • DISABLE: Enable Brave Shields v2
  • ENABLE: Enable Brave Shields v1

@justsomeone1 thanks for the suggestion, in both cases (working vs nonworking) profile, the Preferences file has the same permissions, both writable by me.

1 Like

@289wk Thanks, yes, I did that on the previous, default profile and it fixed the problem for about a week, then the same problem came back again. I was hoping there was a fix that didn’t cause me to re-approve all the sites I use again (or each time this decides to happen after clearing all again).

@Mattches and others, after running the new test profile for a few weeks, the problem has recurred in that new test profile. Any new site I visit has shields off. I’d hate to think I need to start over yet again :frowning: Suggestions?

1 Like

Do you have extensions installed in the browser at this time?

@Mattches, Only Bitwarden.

@mattches @289wk Any thoughts? Thanks.