Shields breaking everything

Description of the issue:

Shields is disabling javascript which prevents most sites from working properly. So I turn off Shields and without it enabled I get ads. Even this forum uses javascript and does not work properly with Shields enabled. This started happening after a series of updates from Brave in recent weeks.

Exact URL of the website in question:

Pretty much all of them.

Screenshot of the ad as it appears in Brave
Did the issue present with default Shields settings? (yes/no)

I assume it was in default as I’ve never messed with any of it’s settings aside from disabling it for the sites that stopped working.

Does the site function as expected when Shields are turned off?

Yes except that now I get ads where I didn’t before.

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):

As above I assume it’s default settings.

Does the site work as expected when using Chrome?

Brave version (check About Brave):

Version 1.25.70 Chromium: 91.0.4472.77 (Official Build) (64-bit)

Make sure you’ve “Script blocker” disabled in your global Shields settings.

1 Like

Thank you for the quick response. I dunno about ads yet but at least sites seem to be working.

You can set the global setting for the ad blocker to “aggressive” if you want. And these articles may help you to learn more about Shields – the default settings and how to

Came here looking for a solution myself.

If I have to take down shields on every single web site I use what’s the point in using Brave?

I think I was safer using ublock and privacy badger in Chrome and never having to disable anything?

Whats the site issue you’re having? Occasionally some sites don’t play well with blocking trackers or cookies. We have some methods to get around this @JordanAustin

Start with this website, will not load properly to login with shields up.

@JordanAustin What doesn’t work exactly? Just re-tested my login, user/pass + 2FA no issues signing in.

Try in a private window, or a new Brave profile.

@JordanAustin: it works perfectly for me.
what is broken in the site?

You can either adjust per site shields (in the address bar) or globally changing shields via brave://settings/shields

I think the problem (at least with me) is that the default setting of not blocking scripts is not working. I’ve always had it set not to block scripts.

This morning I was checking some various news sites, almost all of them failed loading correctly, from blocking scripts. Each and every site I’m having to bring shields down. I would much rather just allow scripts, but the setting doesn’t appear to be working, and the shield itself only allows you to temporarily allow them on a per site basis.

does the setting work in a new profile?

or you can try changing the option directly in the configuration file in your current profile: close brave, locate your profile directory, open the “Preferences” file with a text editor, and search for the no_script_default string. it should be true, and you should set it to false.
as an example this is the relevant part of my preferences file:

ps remember to make a backup of the config file before editing it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.