Reset to English on iMac

How to reset the primary language to English on my iMac? Settings - Settings - Languages - English
iMac system settings - Languages - General - English
Have no idea why the language changed from preset English but cannot reset it back.
Thanks

brave://settings/languages

When you start Brave for the first time, it will set the language according to your system, but after that, your system won’t affect it and you can manually add and remove any language you want. you click the 3 dots and set it to “Display Brave in this language”

Thanks, apparently I did not communicate the fact I did just that with no results.

Well, you need to post a screenshot of the languages page then. Your information is confusing, like what does “Preset English” mean or what language is your Brave displaying right now.

Brave includes a screenshot functionality so, no there can’t be more excuses to make the post better by providing more information. You can enable the flags brave://flags/#sharing-desktop-screenshots
and brave://flags/#sharing-desktop-screenshots-edit

then you use the share icon in the address bar to access it.

image

once you marquee select the portion you want to screenshot you only ctrl+v in the post, so it is easier to understand what if Brave doing on your side.

Followed the instructions to post a screenshot, while downloading the icon the language problem corrected itself. Something is wrong with Brave with regard to settings - preferred languages… (could not describe everything properly since it was in Spanish). I am not a coder but it is now corrected.

Browser has to be restarted when you change language so maybe it didn’t get properly restarted before.