Search is going directly to page in history instead of searching

Whenever I try to search for “amtrak” right now, it doesn’t search. Instead, it goes directly to

This is specifically on my Android device, but I’ve experienced the same behavior on Ubuntu.

I’m pretty sure this is important: I have “Show autocomplete in address bar” disabled. Whenever I re-enable it, that url is what it auto-completes to. (Of course, keeping auto-complete on is not an option.)

Steps to Reproduce:

I think this will work, but it’s kind of an odd thing to reproduce.

  1. Disable “Show autocomplete in address bar”.
  2. Type or copy/paste a url in the url/search bar that has a path other than the root in it, e.g.
  3. Try to search that domain as a keyword.

Actual Result: It will go to a page in the history (in that example, Denny’s Tumblr page).

Expected result: It will search the web for “Tumblr”.

Reproduces how often: Every time I search this term.

Operating System and Brave Version: Android 10, Brave 1.52.130.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.