Scroll bar doesn't dissapear

I am on a MacBook Pro using Brave and the scroll bar on each page doesn’t disappear - even when, for example, I full-screen a YouTube video. I tried restarting my computer and everything, too, and no luck.

Hi @sj1919,
What build and version of Brave are you using?
Can you send us a picture/gif of the issue you’re seeing.

1 Like

Using [Version 1.5.123 Chromium: 80.0.3987.163 (Official Build) (64-bit)

Can see it here:


Can you try creating a new profile and seeing if the issue persists?
Click on the menu icon in the top right corner > create new profile.

@Aa-ron tried and same thing is still happening

@Aa-ron I also updated Brave to the even more current version and still not working. And now the scroll bar is also seems to be brighter possibly too? It seems that way

Can you try going to System Preferences, click on the General, and look for the Show scroll bars section. Is always toggled?

@Aa-ron it says “Automatically based on mouse or trackpad”
(I have a laptop)

Can you try toggling that to always, quit and then restart Brave. Then change it back to Automatically, quit and then restart brave again.

Have you changed anything within brave://flags ?

Have you tested this in other browsers, e.g. Chrome? Does the scroll bar not disappear in Chrome?

@Aa-ron tried those steps and still nothing

within brave://flags I didn’t even know that existed so I have not gone into change anything

It does not happen in Chrome and other browsers

Can you try going back into system preferences and changing it to when scrolling?

@Aa-ron just tried, same issue still

@Aa-ron is this something other people have had issues with? any solutions?

@Aa-ron Following up on this again.

@sj1919 @Aa-ron
You don’t happen to have Logitech’s software installed by any chance? Like the “Logi Options” or more important the “Logitech Unifying” extension?

Or other 3rd party mouse / keyboard drivers like Wacom’s kernel extension based drivers?

Some of these tools can interfere with the main thread where Scrollbar scrolling in Chromium / Chrome / Brave happens by default until a later release.
Note this main thread interference can also cause scrolling issues when using the mouse / trackpad if the main thread is busy, due to reasons like long running JS, erroneous drivers / software working in the browser context etc.

As a workaround try enabling:
brave://flags in the address bar and search for “Compositor threaded scrollbar scrolling” and try enabling that.

This would of course not solve the underlying reason for the problem if it works, if it’s caused by some of the mentioned, but it would be like taking pain-killers until surgery finally happens…
At least you’d not be seeing that ugly scrollbar constantly.

Your macOS setting for showing scrollbar based on input is correct.

@cseder @Aa-ron no, I don’t have Logi Options or the Logitech Unifying extension. I don’t have any other mouse/keyboard drivers.

I tried enabling that Compositer threadbar scrollbar scrolling in brave://flags but it didn’t change anything

Also why did you comment post withdrawn by author? I’ve done nothing but follow up about it for an issue that’s clearly not resolved…

Apologies for the late reply.
Would you be willing to download one of Brave’s other builds to test if the issue also happens there?

@Aa-ron would it change or lose anything from my current browser settings / bookmarks / logins etc?

No, each Build will have its own settings. You can run them side by side.

@Aa-ron I tried both and they each download successfully but then don’t open for me. Keeps crashing before it even opens the window. A message pops up saying they quit unexpectedly and then “Click Reopen to open the application again. Click Report to see more detailed information and send a report to Apple.” but if I try to hit Reopen, it just pops up the same message again.