is not loading on Brave browser

Whenever i try to go on, it loads for a while and shows me this message “This site is unavailable took too long to respond.” this happen 3 days ago and is still happening. I dont understand why it wont work. Someone please help

It works fine if i go on Google Chrome… but after using Brave for a while i prefer using this and not google chrome, so id be happy to get some help

1 Like

@karri I just went and tested. I can’t replicate your issue, which suggests it is something to do with your device. That said, it doesn’t help that you provided little to no information as well. Generally, it’s good to share:

  • Which version of Brave you’re using

  • Which OS you’re on

Then on things with websites not working, usually good to check:

  • Does disabling Shields make a difference?

  • Does it work in private window?

  • If you Add new profile (desktop only), does it work?

  • Are you using a VPN or proxy? If so, disable and test.

Just to show…been open. I was able to create an account and navigate around with no problems. Also just to show the steps I had to take in the browser when testing after creating the account:



But yeah, everything seems to work just fine. Also, seeing all of this, it kind of gives you an example as well where more information is important. Such as:

  • Were you signed in?
  • Were you at the loading thing from where you were trying to open a game (such as my next to last screenshot).
  • Is it any particular game or link on Roblox that has that issue or does it appear regardless of what you try?

Always lots of little details, all of which can be very important…

1 Like

my bad for so little info. but here. Im logged in to my account

  • It does not work in private window either, get the same picture as the first
  • The shields are off and not work
  • Still doesnt work with adding new profile
  • Not using VPN or proxy as of i know of. I’ve never turned it on
    Just trying to go on “” doesnt work for me

Not just speaking about Brave’s VPN or anything. But anything like that which might be on your device. That said, I’ll assume for now the answer is you don’t.

What I’ll suggest on that for now is for you to check some of the details from Roblox support below:

This makes it sound like it would be an issue with your internet, firewall, or even antivirus.

  • Private window and new profile both it helped make sure extensions weren’t causing it.

  • Private and new profile also created new instances with new cookies, so no cookie should be causing your problem.

  • New profile would be default settings, so any changes you might have made to network or anything should have been undone on that, so makes it seem like it’s not any setting within Brave causing problems

  • Shields off would tell us that it’s not the adblock preventing the page from loading.

  • By me not being able to replicate, it shows that the site is available and Brave should be able to connect.

Only exception to the above is if you added extensions or changed settings when you created the second profile. If you did that, then try another new profile without making changes.

The next things to try will be:

  1. Try downloading Brave Beta or Brave Nightly and see if the issue happens there.

  2. Back on original Brave, check to see if you changed anything at brave://flags. These changes persist across profiles.

Thank you for trying to help!

I tried dowloading both Brave Beta and Brave Nightly, i got the same picture as before “this site cant be reached” with and without using Brave Shields

But about the VPN, i dont use it, not on any devices.

About roblox not working happen as i said 3 days ago or something like that. I have not changed anything from how I have used to play and launch anything on my pc. I havent changed any setting on pc or on browser. It just randomly happen one morning, it wouldnt work.

-I tried checking my firewall on my settings, turned roblox off and back on there, still doesnt work.
-Checked at brave://flags, i have never changed anything there, but i clicked to reset all just in case, still doesnt work

Ill try check out my internet or antivirus too when i have time, but as Roblox is working on Chrome and Edge, i dont understand why it just suddenly stopped working on Brave

okay i dont know what happen. im guessing the link that was saved into my search bar was somehow broken. Roblox works now it seems like

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.